Bug 1278325 - DHT: Once remove brick start failed in between Remove brick commit should not be allowed
DHT: Once remove brick start failed in between Remove brick commit should not...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
All Unspecified
medium Severity medium
: ---
: ---
Assigned To: Atin Mukherjee
: ZStream
Depends On: 1258875
Blocks: 1332370 1333237
  Show dependency treegraph
 
Reported: 2015-11-05 04:32 EST by Sakshi
Modified: 2017-03-27 14:21 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258875
: 1332370 1333237 (view as bug list)
Environment:
Last Closed: 2017-03-27 14:21:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sakshi 2015-11-05 04:32:17 EST
+++ This bug was initially created as a clone of Bug #1258875 +++

Document URL: 
=============
DHT: Once remove brick start failed in between Remove brick commit should not be allowed 

Steps:
========
1. Create a distributed volume with three bricks and mount it on client using FUSE
2. From the mount point create lots of directories and one direcotry with 30k files
3. Remove one of the brick form the volume and while re-blance is in progress delete all directories and files from the mount point and due to this remove-brick operation failed 
4.Though remove-brick operation failed remove-commint job is getting succeeded, 

Expected Result:
================
Remove-brick commit should be allowed only when the remove-brick operation job is passed
Comment 1 Sakshi 2016-01-08 04:18:00 EST
Patch posted at http://review.gluster.org/#/c/12513/
Comment 2 Vijay Bellur 2016-02-04 03:59:26 EST
REVIEW: http://review.gluster.org/12513 (glusterd: remove-brick commit should not be allowed when remove-brick start failed) posted (#2) for review on master by Sakshi Bansal
Comment 3 Vijay Bellur 2016-02-24 05:13:21 EST
REVIEW: http://review.gluster.org/12513 (glusterd: remove-brick commit should not succeed when migration failed) posted (#3) for review on master by Sakshi Bansal
Comment 4 Mike McCune 2016-03-28 19:31:34 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Vijay Bellur 2016-04-07 02:33:24 EDT
REVIEW: http://review.gluster.org/12513 (glusterd: remove-brick commit should not succeed when migration failed) posted (#4) for review on master by Sakshi Bansal
Comment 6 Vijay Bellur 2016-05-02 23:53:22 EDT
COMMIT: http://review.gluster.org/12513 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 614a048c59d9b22e090acc0f1bdcb8c1be67f97a
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Thu Nov 5 15:09:31 2015 +0530

    glusterd: remove-brick commit should not succeed when migration failed
    
    While remove a brick if the data migration was not successful,
    remove-brick commit should not succeed as this can lead to
    data loss.
    
    Change-Id: I1eac0ef775cc6910ece0e46ebb04051444d54393
    BUG: 1278325
    Signed-off-by: Sakshi Bansal <sabansal@localhost.localdomain>
    Reviewed-on: http://review.gluster.org/12513
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Atin Mukherjee <amukherj@redhat.com>
Comment 9 Shyamsundar 2017-03-27 14:21:34 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.