Bug 1278346 - Data Tiering:Regression:NFS crashed due to dht readdirp after attach tier
Data Tiering:Regression:NFS crashed due to dht readdirp after attach tier
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
urgent Severity urgent
: ---
: RHGS 3.1.2
Assigned To: Mohammed Rafi KC
Sweta Anandpara
: ZStream
: 1278345 (view as bug list)
Depends On: 1260003
Blocks: 1260783 1260923
  Show dependency treegraph
 
Reported: 2015-11-05 05:18 EST by nchilaka
Modified: 2016-09-17 11:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1260003
Environment:
Last Closed: 2016-03-01 00:51:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server and client logs (34.60 KB, application/vnd.oasis.opendocument.text)
2015-12-04 09:03 EST, Sweta Anandpara
no flags Details

  None (edit)
Comment 2 Vivek Agarwal 2015-11-05 05:44:18 EST
*** Bug 1278345 has been marked as a duplicate of this bug. ***
Comment 4 Sweta Anandpara 2015-12-04 09:02:25 EST
Tested and verified this on the build glusterfs-3.7.5-7.el7rhgs.x86_64

Had a 4+2 disperse volume, and created 100 files via the fuse mountpoint.. Attached a 2*2 tier and continued to create files. New files were created on the hot tier. No crashes were observed. Had a duplicate mountpoint on the same client and did nfs I/O. File movement was as expected.

Changed the mode to test and set the read/write counters to 4. Heated 10 files 5 times, the other 10, 3 times and verified the movement of those files between hot and cold tiers. On no access to the files, they were moved back from hot to cold, after the session time. 

Moving this bug to verified in 3.1.2. Detailed logs are attached. 

If there is anything specific to be tested more regarding the fix of this bug, please do write.
Comment 5 Sweta Anandpara 2015-12-04 09:03 EST
Created attachment 1102281 [details]
Server and client logs
Comment 7 errata-xmlrpc 2016-03-01 00:51:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.