Bug 1278359 - Intermittent Cinder Broken Pipe ConnectionError [NEEDINFO]
Intermittent Cinder Broken Pipe ConnectionError
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
6.0 (Juno)
x86_64 Linux
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: Eric Harney
nlevinki
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 05:32 EST by John Chronister
Modified: 2016-04-27 00:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-14 09:43:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgotliv: needinfo? (jchronis)


Attachments (Terms of Use)

  None (edit)
Description John Chronister 2015-11-05 05:32:40 EST
Description of problem: When attaching a volume to an active VM occasionally there are broken pipe errors and the operation fails. 


Version-Release number of selected component (if applicable): RHOSP6 Juno

Environment Configuration NOTES:  

3 node cluster with NFS glance backend
VMWare Datastore and NFS cinder backend
VMWare vCenter and KVM nova backend
DVS plugin and OpenvSwitch neutron Backend



How reproducible:

Intermittent failure.  Unable to reproduce consistently.


Steps to Reproduce:
1.  Attaching a volume to an active VM.


Actual results:
Operation fails with broken pipe errors.


Additional info:
Complete sosreports available.
Comment 2 Sergey Gotliv 2015-11-12 02:30:18 EST
John,

Can you, please, replroduce the case and upload the relevant sos reports to collab shell? We can't investigate issues without logs.

Note You need to log in before you can comment on or make changes to this bug.