Bug 1278370 - [GSS] (6.4.z) start-delivery/stop-delivery operations are missing from MDB deployment in domain mode when using Console
[GSS] (6.4.z) start-delivery/stop-delivery operations are missing from MDB de...
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JMS (Show other bugs)
6.4.0
Unspecified Unspecified
urgent Severity urgent
: CR1
: EAP 6.4.5
Assigned To: Dmitrii Tikhomirov
Miroslav Novak
:
Depends On: 1266913
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 06:02 EST by Tom Ross
Modified: 2015-12-02 03:04 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1266913
Environment:
Last Closed: 2015-11-09 05:21:24 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFCORE-1111 Major Resolved Expose runtime methods in JMX for resources in domain servers 2017-08-24 18:42 EDT
JBoss Issue Tracker WFLY-5418 Major Resolved start-delivery/stop-delivery operations descriptions are missing from MDB deployment in domain mode 2017-08-24 18:42 EDT

  None (edit)
Comment 5 Vaclav Tunka 2015-11-09 05:21:24 EST

*** This bug has been marked as a duplicate of bug 1266913 ***
Comment 6 Jeff Mesnil 2015-11-09 05:33:20 EST
This issue was not a duplicate of #1266913.

EAP 6.4 does not expose RUNTIME_ONLY operations in JMX. This would be a new feature and this must be dealt appropriately. This does not only concern the start/stop-delivery operations but *any* RUNTIME_ONLY operations on resources in domain servers.

This BZ was created to make sure that the fix to expose start/stop-delivery in domain mode would be fixed independently and then we could use appropriate channel to decide to expose RUNTIME_ONLY operations in JMX  for EAP 6.
Comment 7 Vaclav Tunka 2015-11-09 05:39:08 EST
Thanks for the clarification Jeff, we will take this BZ to triage today to deal with it appropriately. I was wondering in upstream this was tracked only in single jira: WFLY-5418
Comment 8 Jeff Mesnil 2015-11-09 05:41:32 EST
sorry, I forgot to link the upstream issue (WFCORE-1111)

Note You need to log in before you can comment on or make changes to this bug.