Bug 1278388 - odb fails to run
odb fails to run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: odb (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dave Johansen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 06:36 EST by Roger Noble
Modified: 2015-12-12 23:24 EST (History)
3 users (show)

See Also:
Fixed In Version: odb-2.4.0-7.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-12 23:24:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger Noble 2015-11-05 06:36:48 EST
Description of problem:

odb fails to run. It always responds with:

unable to open file '' or read failure

irrespective of any command line parameters.

Version-Release number of selected component (if applicable):

2.4.0-5

How reproducible:

Always


Steps to Reproduce:

1. For example type odb --version at the command line.

Actual results:

Prints
unable to open file '' or read failure

Expected results:

obd to print its version number, or with suitable parameters to generate C++ code.

Additional info:
Comment 1 Fedora Update System 2015-11-07 09:12:34 EST
odb-2.4.0-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b9dd312a82
Comment 2 Fedora Update System 2015-11-08 08:23:47 EST
odb-2.4.0-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update odb'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b9dd312a82
Comment 3 Roger Noble 2015-11-09 15:25:59 EST
I've updated to 2.4.0-6 from updates-testing but unfortunately the problem still persists :(
Comment 4 Andrei Prescornic 2015-11-15 16:33:23 EST
Same problem
Fedora release 23 (Twenty Three)

gcc version 5.1.1 20150618 (Red Hat 5.1.1-4) (GCC) 

odb-2.4.0-6.fc23.x86_64
odb -v
unable to open file '' or read failure

uname -a
Linux ntbAndrei 4.2.5-300.fc23.x86_64 #1 SMP Tue Oct 27 04:29:56 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Comment 5 Dave Johansen 2015-11-15 22:04:05 EST
The previous update for the gcc rebuild was unrelated to this issue. It appears that this is caused by an issue with libcutl and I'm investigating a fix.
Comment 6 Fedora Update System 2015-11-25 11:17:13 EST
odb-2.4.0-7.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-75f460b610
Comment 7 Fedora Update System 2015-11-25 21:53:09 EST
odb-2.4.0-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update odb'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-75f460b610
Comment 8 Andrei Prescornic 2015-11-26 03:17:00 EST
fixed 
odb --version
ODB object-relational mapping (ORM) compiler for C++ 2.4.0
Copyright (c) 2009-2015 Code Synthesis Tools CC
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

libcutl 1.10.0-1.fc23                            
odb     2.4.0-7.fc23    


thanks a lot.
Comment 9 Roger Noble 2015-12-04 11:43:13 EST
xsd-4.0.0-10 depends on libcutl-1.9, so I guess that this needs an update as well.
Comment 10 Fedora Update System 2015-12-12 23:24:00 EST
odb-2.4.0-7.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.