Bug 1278398 - Unable to build master on EL7 due to missing objenesis package dependency
Unable to build master on EL7 due to missing objenesis package dependency
Status: CLOSED NEXTRELEASE
Product: ovirt-release
Classification: oVirt
Component: Packaging.rpm (Show other bugs)
master-001
Unspecified Unspecified
high Severity low (vote)
: ovirt-4.0.0-alpha
: master-002
Assigned To: Sandro Bonazzola
Pavel Novotny
: BuildBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 06:53 EST by Martin Perina
Modified: 2016-03-17 05:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 05:31:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48172 master MERGED ovirt-release-master: add missing builddep on el7 Never

  None (edit)
Description Martin Perina 2015-11-05 06:53:53 EST
Description of problem:

Current master cannot be built on EL7 due to missing objenesis package in ovirt-master-epel repo:

yum-builddep /root/rpmbuild/SRPMS/ovirt-engine-4.0.0-0.0.master.20151104112643.el7.centos.src.rpm
Getting requirements for ovirt-engine-4.0.0-0.0.master.20151104112643.el7.centos.src
 --> assertj-core-2.2.0-1.el7.noarch
 --> 1:java-1.8.0-openjdk-devel-1.8.0.65-2.b17.el7_1.x86_64
 --> Already installed : javapackages-tools-3.4.1-6.el7_0.noarch
 --> Already installed : 1:make-3.82-21.el7.x86_64
 --> Already installed : maven-3.0.5-16.el7.noarch
 --> Already installed : python-2.7.5-18.el7_1.1.x86_64
 --> Already installed : unzip-6.0-15.el7.x86_64
 --> Already installed : systemd-208-20.el7_1.6.x86_64
--> Running transaction check
---> Package assertj-core.noarch 0:2.2.0-1.el7 will be installed
--> Processing Dependency: mvn(org.mockito:mockito-core) for package: assertj-core-2.2.0-1.el7.noarch
---> Package java-1.8.0-openjdk-devel.x86_64 1:1.8.0.65-2.b17.el7_1 will be installed
--> Running transaction check
---> Package mockito.noarch 0:1.9.0-18.el7 will be installed
--> Processing Dependency: objenesis for package: mockito-1.9.0-18.el7.noarch
--> Finished Dependency Resolution
Error: Package: mockito-1.9.0-18.el7.noarch (ovirt-master-snapshot-static)
           Requires: objenesis
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


After adding objenesis package to includepkgs option in ovirt-master-epel repo, build works fine


Version-Release number of selected component (if applicable):

oVirt master branch

How reproducible:

100%

Steps to Reproduce:
1. Create an SRPM package for master sources
    rpmbuild -D"ovirt_build_minimal 1" -ts ovirt-engine-4.0.0_master.tar.gz
2. Try to install all needed dependencies
    yum-builddep /root/rpmbuild/SRPMS/ovirt-engine-4.0.0-0.0.master.20151104112643.el7.centos.src.rpm


Actual results:

Build failed

Expected results:

Build is working properly

Additional info:
Comment 1 Sandro Bonazzola 2015-11-05 06:59:25 EST
workaround: enable epel repo.

Note You need to log in before you can comment on or make changes to this bug.