Bug 1278405 - Atmel URLs changed
Atmel URLs changed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: avr-libc (Show other bugs)
24
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 07:04 EST by Matthew Sainsbury
Modified: 2016-11-25 02:22 EST (History)
4 users (show)

See Also:
Fixed In Version: avr-libc-2.0.0-1.fc24 avr-libc-2.0.0-1.fc25 avr-libc-2.0.0-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-24 11:28:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix broken URLs (1.27 KB, application/mbox)
2015-11-05 07:04 EST, Matthew Sainsbury
no flags Details

  None (edit)
Description Matthew Sainsbury 2015-11-05 07:04:34 EST
Created attachment 1090036 [details]
Patch to fix broken URLs

Description of problem:
The URLs used in the specfile for this package to download files from the ATMEL website no longer work.

How reproducible:
Any time you try to build the package from scratch

Steps to Reproduce:
1. git clone git://pkgs.fedoraproject.org/avr-libc.git
2. spectool avr-libc/avr-libc.spec -g

Actual results:
Spectool fails with:

Getting http://distribute.atmel.no/tools/opensource/Atmel-AVR-Toolchain-3.4.2/avr/avr-patches.tar.gz to ./avr-patches.tar.gz
curl: (22) The requested URL returned error: 404 Not Found
Getting http://distribute.atmel.no/tools/opensource/Atmel-AVR-Toolchain-3.4.2/avr/avr-headers-6.1.3.1475.zip to ./avr-headers-6.1.3.1475.zip
url: (22) The requested URL returned error: 404 Not Found


Expected results:
Spectool can download all the files required to build

Additional info:
I found the files at http://distribute.atmel.no/tools/opensource/Atmel-AVR-GNU-Toolchain/3.4.2/

I have added a patch to fix this. This is my first time submitting a patch for a fedora package, please forgive any faux pas
Comment 1 Jan Kurik 2016-02-24 08:54:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Thibault North 2016-07-28 06:19:32 EDT
Hello Matthew, 

Thanks for your patch and sorry for not responding. Other stuff IRL kept me busy.

Looks like Atmel doesn't provide patches against avr-libc any more, but rather patched sources.
I'll try and find time to generate a proper patch out of them.
What do you need exactly? Content of the Atmel avr distribution that is not part of the packaged avr-libc?
Thanks,
Comment 3 Matthew Sainsbury 2016-07-29 02:52:42 EDT
Sorry, it's been so long that I can't remember what I was doing when I made this patch. I think I was trying to get early access to a newer version of this package to fix another issue I had (which had been fixed in git but not published yet) and ran into this problem when trying to build the package so I could install it.

I've lost all context on this so I help this ticket is still useful enough to fix the issue.
Comment 4 Fedora Update System 2016-11-13 11:02:42 EST
avr-libc-2.0.0-1.fc23 avr-binutils-2.27-1.fc23 avr-gcc-6.2.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f9189fdac7
Comment 5 Fedora Update System 2016-11-13 11:02:56 EST
avr-libc-2.0.0-1.fc24 avr-binutils-2.27-1.fc24 avr-gcc-6.2.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2459cd6d15
Comment 6 Fedora Update System 2016-11-13 11:03:07 EST
avr-libc-2.0.0-1.fc25 avr-binutils-2.27-1.fc25 avr-gcc-6.2.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7a536a8707
Comment 7 Fedora Update System 2016-11-14 21:25:43 EST
avr-binutils-2.27-1.fc23, avr-gcc-6.2.0-1.fc23, avr-libc-2.0.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f9189fdac7
Comment 8 Fedora Update System 2016-11-14 21:29:44 EST
avr-binutils-2.27-1.fc24, avr-gcc-6.2.0-1.fc24, avr-libc-2.0.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2459cd6d15
Comment 9 Fedora Update System 2016-11-15 08:26:11 EST
avr-binutils-2.27-1.fc25, avr-gcc-6.2.0-1.fc25, avr-libc-2.0.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7a536a8707
Comment 10 Fedora Update System 2016-11-24 11:28:44 EST
avr-binutils-2.27-1.fc25, avr-gcc-6.2.0-1.fc25, avr-libc-2.0.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-11-24 15:27:42 EST
avr-binutils-2.27-1.fc24, avr-gcc-6.2.0-1.fc24, avr-libc-2.0.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-11-25 02:22:15 EST
avr-binutils-2.27-1.fc23, avr-gcc-6.2.0-1.fc23, avr-libc-2.0.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.