Bug 1278447 - ceph.conf properties override qemu's command-line properties
ceph.conf properties override qemu's command-line properties
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
Unspecified Unspecified
high Severity unspecified
: rc
: 7.3
Assigned To: Stefan Hajnoczi
Virtualization Bugs
: ZStream
Depends On: 1277248
Blocks: 1279391 1288337
  Show dependency treegraph
 
Reported: 2015-11-05 09:09 EST by Stefan Hajnoczi
Modified: 2016-11-07 15:52 EST (History)
20 users (show)

See Also:
Fixed In Version: qemu-kvm-rhev-2.6.0-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1277248
: 1279391 (view as bug list)
Environment:
Last Closed: 2016-11-07 15:52:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Miroslav Rezanina 2015-11-18 05:07:19 EST
Fix included in qemu-kvm-rhev-2.3.0-31.el7_2.2
Comment 6 Mike McCune 2016-03-28 19:37:25 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 jingzhao 2016-05-19 02:26:29 EDT
1.Reproduced with qemu-kvm-1.5.3-105.el7.x86_64

[root@intel-3323-24-2 qemu2]# /usr/libexec/qemu-kvm -M pc -S -monitor stdio -vnc none -smp 1 -m 4096 -vga none -drive file=rbd:libvirt-pool/rhel72.raw:mon_host=10.66.144.75,id='rbd',format=raw,cache=none
QEMU 1.5.3 monitor - type 'help' for more information
(qemu) info block
rbd: removable=0 io-status=ok file=rbd:libvirt-pool/rhel72.raw:mon_host=10.66.144.75 ro=0 drv=raw encrypted=0 bps=0 bps_rd=0 bps_wr=0 iops=0 iops_rd=0 iops_wr=0
ide1-cd0: removable=1 locked=0 tray-open=0 io-status=ok [not inserted]
floppy0: removable=1 locked=0 tray-open=0 [not inserted]
sd0: removable=1 locked=0 tray-open=0 [not inserted]

[root@intel-3323-24-2 ceph]# ceph --admin-daemon /var/run/ceph/ceph-client.admin.5734.140180343873536.asok config show |grep rbd_cache
    "rbd_cache": "true",

2.Verified it with qemu-kvm-rhev-2.6.0-1.el7.x86_64

[root@localhost ceph]# /usr/libexec/qemu-kvm -M pc -S -monitor stdio -vnc none -smp 1 -m 4096 -vga none -drive file=rbd:libvirt-pool/rhel7.raw:mon_host=10.66.144.75,id='rbd',format=raw,cache=none
QEMU 2.5.94 monitor - type 'help' for more information
(qemu) warning: host doesn't support requested feature: CPUID.80000001H:ECX.sse4a [bit 6]

(qemu) info block
rbd (#block135): rbd:libvirt-pool/rhel7.raw:mon_host=10.66.144.75 (raw)
    Cache mode:       writeback, direct

ide1-cd0: [not inserted]
    Removable device: not locked, tray closed

floppy0: [not inserted]
    Removable device: not locked, tray closed

sd0: [not inserted]
    Removable device: not locked, tray closed
(qemu) 

[root@localhost ceph]# ceph --admin-daemon /var/run/ceph/ceph-client.admin.18104.140701324165120.asok config show |grep rbd_cache
    "rbd_cache": "false",
Comment 9 Stefan Hajnoczi 2016-06-03 14:23:53 EDT
(In reply to jingzhao from comment #8)
> 1.Reproduced with qemu-kvm-1.5.3-105.el7.x86_64
> 
> [root@intel-3323-24-2 qemu2]# /usr/libexec/qemu-kvm -M pc -S -monitor stdio
> -vnc none -smp 1 -m 4096 -vga none -drive
> file=rbd:libvirt-pool/rhel72.raw:mon_host=10.66.144.75,id='rbd',format=raw,
> cache=none
> QEMU 1.5.3 monitor - type 'help' for more information
> (qemu) info block
> rbd: removable=0 io-status=ok
> file=rbd:libvirt-pool/rhel72.raw:mon_host=10.66.144.75 ro=0 drv=raw
> encrypted=0 bps=0 bps_rd=0 bps_wr=0 iops=0 iops_rd=0 iops_wr=0
> ide1-cd0: removable=1 locked=0 tray-open=0 io-status=ok [not inserted]
> floppy0: removable=1 locked=0 tray-open=0 [not inserted]
> sd0: removable=1 locked=0 tray-open=0 [not inserted]
> 
> [root@intel-3323-24-2 ceph]# ceph --admin-daemon
> /var/run/ceph/ceph-client.admin.5734.140180343873536.asok config show |grep
> rbd_cache
>     "rbd_cache": "true",
> 
> 2.Verified it with qemu-kvm-rhev-2.6.0-1.el7.x86_64
> 
> [root@localhost ceph]# /usr/libexec/qemu-kvm -M pc -S -monitor stdio -vnc
> none -smp 1 -m 4096 -vga none -drive
> file=rbd:libvirt-pool/rhel7.raw:mon_host=10.66.144.75,id='rbd',format=raw,
> cache=none
> QEMU 2.5.94 monitor - type 'help' for more information
> (qemu) warning: host doesn't support requested feature:
> CPUID.80000001H:ECX.sse4a [bit 6]
> 
> (qemu) info block
> rbd (#block135): rbd:libvirt-pool/rhel7.raw:mon_host=10.66.144.75 (raw)
>     Cache mode:       writeback, direct
> 
> ide1-cd0: [not inserted]
>     Removable device: not locked, tray closed
> 
> floppy0: [not inserted]
>     Removable device: not locked, tray closed
> 
> sd0: [not inserted]
>     Removable device: not locked, tray closed
> (qemu) 
> 
> [root@localhost ceph]# ceph --admin-daemon
> /var/run/ceph/ceph-client.admin.18104.140701324165120.asok config show |grep
> rbd_cache
>     "rbd_cache": "false",

What is the status of this bug?  Should it be set to VERIFIED?
Comment 10 Chao Yang 2016-06-13 04:27:37 EDT
(In reply to Stefan Hajnoczi from comment #9)
> (In reply to jingzhao from comment #8)
> > 1.Reproduced with qemu-kvm-1.5.3-105.el7.x86_64
> > 
> > [root@intel-3323-24-2 qemu2]# /usr/libexec/qemu-kvm -M pc -S -monitor stdio
> > -vnc none -smp 1 -m 4096 -vga none -drive
> > file=rbd:libvirt-pool/rhel72.raw:mon_host=10.66.144.75,id='rbd',format=raw,
> > cache=none
> > QEMU 1.5.3 monitor - type 'help' for more information
> > (qemu) info block
> > rbd: removable=0 io-status=ok
> > file=rbd:libvirt-pool/rhel72.raw:mon_host=10.66.144.75 ro=0 drv=raw
> > encrypted=0 bps=0 bps_rd=0 bps_wr=0 iops=0 iops_rd=0 iops_wr=0
> > ide1-cd0: removable=1 locked=0 tray-open=0 io-status=ok [not inserted]
> > floppy0: removable=1 locked=0 tray-open=0 [not inserted]
> > sd0: removable=1 locked=0 tray-open=0 [not inserted]
> > 
> > [root@intel-3323-24-2 ceph]# ceph --admin-daemon
> > /var/run/ceph/ceph-client.admin.5734.140180343873536.asok config show |grep
> > rbd_cache
> >     "rbd_cache": "true",
> > 
> > 2.Verified it with qemu-kvm-rhev-2.6.0-1.el7.x86_64
> > 
> > [root@localhost ceph]# /usr/libexec/qemu-kvm -M pc -S -monitor stdio -vnc
> > none -smp 1 -m 4096 -vga none -drive
> > file=rbd:libvirt-pool/rhel7.raw:mon_host=10.66.144.75,id='rbd',format=raw,
> > cache=none
> > QEMU 2.5.94 monitor - type 'help' for more information
> > (qemu) warning: host doesn't support requested feature:
> > CPUID.80000001H:ECX.sse4a [bit 6]
> > 
> > (qemu) info block
> > rbd (#block135): rbd:libvirt-pool/rhel7.raw:mon_host=10.66.144.75 (raw)
> >     Cache mode:       writeback, direct
> > 
> > ide1-cd0: [not inserted]
> >     Removable device: not locked, tray closed
> > 
> > floppy0: [not inserted]
> >     Removable device: not locked, tray closed
> > 
> > sd0: [not inserted]
> >     Removable device: not locked, tray closed
> > (qemu) 
> > 
> > [root@localhost ceph]# ceph --admin-daemon
> > /var/run/ceph/ceph-client.admin.18104.140701324165120.asok config show |grep
> > rbd_cache
> >     "rbd_cache": "false",
> 
> What is the status of this bug?  Should it be set to VERIFIED?

Yes.

Moving to VERIFIED per Comment 8
Comment 12 errata-xmlrpc 2016-11-07 15:52:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html

Note You need to log in before you can comment on or make changes to this bug.