Bug 1278455 - abrt-handle-upload broken
abrt-handle-upload broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Filak
Martin Kyral
: EasyFix, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 09:27 EST by Martin Kyral
Modified: 2016-05-10 20:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: abrt-2.0.8-36.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:39:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kyral 2015-11-05 09:27:30 EST
Description of problem:
The upload-handling upstream test constantly fails due to this problem:

[0 root@qeos-20 upload-handling]# reporter-upload -d problem_dir -u file:///var/spool/abrt-upload/upload.tar.gz
Compressing data
Sending /tmp/problem_dir.tar.gz to file:///var/spool/abrt-upload/upload.tar.gz
Successfully sent /tmp/problem_dir.tar.gz to file:///var/spool/abrt-upload/upload.tar.gz
[0 root@qeos-20 upload-handling]# ls /var/spool/abrt-upload/
upload.tar.gz
[0 root@qeos-20 upload-handling]# abrt-handle-upload -v /var/spool/abrt /var/spool/abrt-upload upload.tar.gz
Can't create working directory in '@LARGE_DATA_TMP_DIR@'
[0 root@qeos-20 upload-handling]#

Version-Release number of selected component (if applicable):
abrt-2.0.8-34.el6

How reproducible:
Always

Steps to Reproduce:
1. see description

Actual results:


Expected results:


Additional info:
Comment 1 Jakub Filak 2015-11-05 09:47:46 EST
The src/daemon/abrt-handle-upload file must be renamed to src/daemon/abrt-handle-upload.in because the file contains variables replaced by the config.sh script. The bug has been introduced with the fixes for bug #1212953.
Comment 3 Jakub Filak 2015-11-06 07:12:55 EST
I've pushed commit https://github.com/abrt/abrt/commit/a09d77ba317d85599bfece21091b8a6f18c2f1bb to rhel-6.8-staging.
Comment 9 errata-xmlrpc 2016-05-10 20:39:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0920.html

Note You need to log in before you can comment on or make changes to this bug.