Bug 1278478 - totemconfig: Make sure join timeout is less than consensus
totemconfig: Make sure join timeout is less than consensus
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync (Show other bugs)
6.8
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Jan Friesse
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 10:03 EST by Jan Friesse
Modified: 2016-05-10 15:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: corosync-1.4.7-3.el6
Doc Type: Bug Fix
Doc Text:
No doc text needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:42:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.38 KB, patch)
2015-11-05 10:03 EST, Jan Friesse
no flags Details | Diff
Proposed patch 2 (10.46 KB, patch)
2015-11-05 10:06 EST, Jan Friesse
no flags Details | Diff

  None (edit)
Description Jan Friesse 2015-11-05 10:03:32 EST
Created attachment 1090140 [details]
Proposed patch

Description of problem:
The thesis contains this paragraph:

  "The Join timeout is shorter than the Consensus timeout and is used
   to increase the probability that Join messages from all currently
   working processors are received during a single round of
   consensus."

Empirically I can confirm that making join less than consensus can
cause havoc with a cluster so I think we should enforce this.


Version-Release number of selected component (if applicable):
1.4.7

Expected results:
Set consensus timeout < join_timeout result is
"The consensus timeout parameter (X ms) may not be less than join timeout (X ms)"

Additional info:
This is change in coroparse which is not used directly when using cman, so this is SanityOnly.
Comment 1 Jan Friesse 2015-11-05 10:06 EST
Created attachment 1090141 [details]
Proposed patch 2

config: Fix 'then' for 'than' typos in messages and some comments.

Also fix a 'delier' for 'deliver', which I only spotted because the line
had a (correct) 'then' on it!
Comment 6 errata-xmlrpc 2016-05-10 15:42:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0753.html

Note You need to log in before you can comment on or make changes to this bug.