Bug 1278492 - manpage for recv() should specify flags behaviour for recvfrom() and recvmsg()
manpage for recv() should specify flags behaviour for recvfrom() and recvmsg()
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
7.2
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Nikola Forró
Iveta Wiedermann
: EasyFix, ManPageChange, Patch
Depends On: 1361588
Blocks: 1349844
  Show dependency treegraph
 
Reported: 2015-11-05 10:32 EST by Jeremy Harris
Modified: 2016-11-04 03:31 EDT (History)
4 users (show)

See Also:
Fixed In Version: man-pages-overrides-7.3.1-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 03:31:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (476 bytes, patch)
2016-02-26 05:46 EST, Nikola Forró
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2485 normal SHIPPED_LIVE man-pages-overrides bug fix and enhancement update 2016-11-03 10:09:10 EDT

  None (edit)
Description Jeremy Harris 2015-11-05 10:32:52 EST
Description of problem:

  The recv() manpage also covers recvfrom() and recvmsg().  Where it discusses
the "flags" argument (which is present in all three calls) it says:
"The flags argument to a recv() call"... and leaves the other two undefined.


Version-Release number of selected component (if applicable):
  Red Hat Enterprise Linux Workstation release 7.2 Beta (Maipo)


How reproducible:
  100%

Steps to Reproduce:
1. man recvmsg
2.
3.

Actual results:

"The flags argument to a recv() call"


Expected results:

"The flags argument"...  is what the Fedora 22 manpage has; seems reasonable.


Additional info:

  RHEL 4 had a separate manpage [ recvmsg(P) ] which pretty much follows the
POSIX http://pubs.opengroup.org/onlinepubs/009695399/functions/recvmsg.html

Both have slightly conflicting information:  The MSG_WAITALL/SOCK_STREAM
behaviour specified in the "flags" section says it waits for the complete
request - but later (2 paras., dealing with return value) says it returns
"as soon as" without making a MSG_WAITALL exception.

You have to assume the flag-specific behaviour takes precedence, but a lawyer
could easily argue the point.
Comment 2 Nikola Forró 2016-02-26 05:46 EST
Created attachment 1130819 [details]
Proposed patch
Comment 9 Michael Kerrisk 2016-09-11 05:00:49 EDT
This problem was already fixed by upstream man-pages commit 4dad515699179f21facd766b9247b955183cffc2 back in Feb 2014.
Comment 11 errata-xmlrpc 2016-11-04 03:31:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2485.html

Note You need to log in before you can comment on or make changes to this bug.