Bug 1278551 - paprefs does not apply changes to /etc/pulse/
paprefs does not apply changes to /etc/pulse/
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: paprefs (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 13:50 EST by cornel panceac
Modified: 2016-08-08 03:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-01 04:43:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2015-11-05 13:50:38 EST
Description of problem:
Trying to make my music play on the desktop that is connected to the audio amplifier, following these instructions

http://fedoramagazine.org/how-to-play-audio-on-another-fedora-system/

i've found that was worked fine in Fedora 21 no longer works in Fedora 22 or 23.

Reading here and there i've understand that paprefs it's a gui editor for files in /etc/pulse/ (more exactly default.pa). Please correct me if i'm wrong. However, comparing the files before and after making changes in paprefs, i've found that their md5sum remains the same, even if in paprefs changes seems to be "memorized" somehow.


Version-Release number of selected component (if applicable):
latest tested is

paprefs-0.9.10-10.fc23.i686


How reproducible:
always

Steps to Reproduce:
1.display md5sum of files in /etc before change
2.change things in paprefs
3.display the new md5sums

Actual results:
sums remains constant

Expected results:
sums change

Additional info:
Comment 1 cornel panceac 2015-11-05 13:56:19 EST
It does not matter if i run paprefs as root or user. 

Also, after reboot, paprefs has still memorized those changes but the files in /etc/pulse/ are still unchanged.
Comment 2 Sylvain Baubeau 2016-07-27 02:49:29 EDT
paprefs does not edit configuration files but uses GConf to "memory" settings.

If you enable the checkbox in paprefs and run the "pactl list modules | grep zeroconf" command, you should see that the "module-zeroconf" is loaded. Could you please confirm that it works ?
Comment 3 cornel panceac 2016-07-27 15:22:23 EDT
pactl list modules | grep zeroconf
returns nothing, in fedora 23.
but i'll reboot and try again.
Comment 4 cornel panceac 2016-07-27 15:31:42 EDT
ok, after reboot and enabling both settings, i see publish and discover modules.
next will be to test if the setup really works. unfortunately this will be left for tomorrow (hopefully).
Comment 5 cornel panceac 2016-07-30 15:17:59 EDT
i can confirm that it's working now. in the meantime i've upgraded the computers to f24 but it's ok for me.
thank you for your help.
Comment 6 Sylvain Baubeau 2016-08-01 04:43:10 EDT
Great. Glad to help. Closing the bug if it's ok for you.
Comment 7 cornel panceac 2016-08-06 14:19:02 EDT
Sure. However i feel that currentrelease is a more appropriate reason for closure. Is this ok for you too?
Comment 8 Sylvain Baubeau 2016-08-08 03:46:07 EDT
It's definitely ok for me.

Note You need to log in before you can comment on or make changes to this bug.