Bug 1278555 - rhevm-doc-ja-JP-3.6.0-1 fails update from 3.5.x
rhevm-doc-ja-JP-3.6.0-1 fails update from 3.5.x
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-doc (Show other bugs)
3.6.0
x86_64 Linux
urgent Severity urgent
: ovirt-3.6.2
: 3.6.2
Assigned To: Greg Sheremeta
Lukas Svaty
:
Depends On:
Blocks: RHEV3.6Upgrade
  Show dependency treegraph
 
Reported: 2015-11-05 13:55 EST by Barak Korren
Modified: 2016-04-12 17:25 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-12 17:25:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine-setup log (882.99 KB, text/plain)
2015-11-05 13:55 EST, Barak Korren
no flags Details

  None (edit)
Description Barak Korren 2015-11-05 13:55:09 EST
Created attachment 1090314 [details]
engine-setup log

Description of problem:
When trying to upgrade ovirt-engine to 3.6.0 from 3.5.x, the upgrade fails.
The following error appears in the logs:

2015-11-05 18:59:56 ERROR otopi.plugins.otopi.packagers.yumpackager yumpackager.error:100 Yum Error unpacking rpm package rhevm-doc-ja-JP-3.6.0-1.el6eng.noarch
2015-11-05 18:59:56 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:91 Yum Script sink: error: unpacking of archive failed on file /usr/share/doc/rhevm-doc/manual/ja-JP: cpio: rename failed - Is a directory

2015-11-05 18:59:56 DEBUG otopi.plugins.otopi.packagers.yumpackager yumpackager.verbose:91 Yum Done: rhevm-doc-ja-JP-3.6.0-1.el6eng.noarch


Version-Release number of selected component (if applicable):
Ugrading to: rhevm-doc-ja-JP-3.6.0-1.el6eng.noarch
From: rhevm-doc-ja-JP.noarch 0:3.5.3-1.el6eng


Added full engine-setup log.
Comment 1 Barak Korren 2015-11-05 14:10:49 EST
Package for 3.6.0 is empty (only two directories) while the 3,5 package contains many files.
Comment 2 Yuko Katabami 2015-11-05 17:05:42 EST
@Barak,

Since GA has been pushed back to March, 3.6 documentation translation will not commence until late Jan 2016.

For rhevm-doc queries, you might want to check with Greg Sheremeta.
Comment 3 Einav Cohen 2015-11-09 08:39:18 EST
(In reply to Barak Korren from comment #1)
> Package for 3.6.0 is empty (only two directories) while the 3,5 package
> contains many files.

@Greg - aren't the docs (in all locales) contain the exact same files as 3.5 at this point?
Comment 4 Greg Sheremeta 2015-11-09 10:41:30 EST
Interesting bug. Looks like we have a candidate for some CI upgrade tests.

...

At this point in the release cycle, each locale's RPM contains two symlinks over to English. Those are the "directories" Barak referred to.

Seems like yum can't handle an upgrade where a directory is changing to a symlink. Ultimately, it's a bug in the packaging of rhevm-doc, and I'll need to fix it.
Comment 5 Yaniv Kaul 2015-12-03 09:19:33 EST
Greg - any updates? I've marked it as urgent severity, as it is upgrade related.
Comment 6 Greg Sheremeta 2015-12-03 09:32:25 EST
Yep, I'll get it fixed today :) Sorry for the delay!
Comment 7 Eyal Edri 2015-12-17 08:58:31 EST
RHEV 3.6.0 BETA2 is out, any open bugs are moved to the BETA3 milestone.
Comment 11 Greg Sheremeta 2015-12-21 23:42:20 EST
3.6.0-2 fixes the issue.
Comment 15 Greg Sheremeta 2015-12-22 11:33:31 EST
This issue also affects

rhevm-doc-ko-KR-3.6.0-1.el6eng
rhevm-doc-zh-CN-3.6.0-1.el6eng
Comment 19 Lukas Svaty 2016-01-21 08:37:13 EST
verified in 
rhevm-3.6.2.6-0.1.el6.noarch
rhevm-doc-ja-JP-3.6.0-2.el6eng.noarch

Note You need to log in before you can comment on or make changes to this bug.