Bug 1278564 - Existing foreman hosts won't recognize updates to the capsules set in the targeted subnet. [NEEDINFO]
Existing foreman hosts won't recognize updates to the capsules set in the tar...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts (Show other bugs)
6.1.2
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 14:47 EST by Dylan Gross
Modified: 2017-04-25 12:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-30 09:24:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bstephen: needinfo?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2041653 None None None Never

  None (edit)
Description Dylan Gross 2015-11-05 14:47:35 EST
Description of problem:

   If the Capsule information has changed since a new foreman host was created, it will not get reflected in the host (unless the host is deleted/re-created, or the MAC address is modified).

 
Version-Release number of selected component (if applicable):

   Observed on Satellite v6.1.2


How reproducible:   Always.

Steps to Reproduce:
1.  Incorrectly, leave the TFTP Capsule as "None" for the desired subnet
2.  Create a "New Host" under the "Hosts"... "All Hosts"
3.  Observe that /var/lib/tftpboot/pxelinux.cfg/01-<mac> is (correctly) not created

4.  Remedy the TFTP Capsule for the subnet by selecting the appropriate TFTP capsule.

5.  Edit the host under "Hosts"..."All Hosts" and then "Submit" again.  

6.  Observe that the /var/lib/tftpboot/pxelinux.cfg/01-<mac> is still not set, even though the TFTP capsule for the subnet is set properly.


Actual results:

   After correcting the TFTP Capsule for the subnet, editing and submitting the host did not create the TFTP entry for the host to be built.


Expected results:

   Editing and submitting the host again would recognize that the current capsule configuration for the subnet and appropriately create the TFTP entry.

Additional info:

   Note:  Easily worked around
    1.  Deleting and re-creating the "New Host" will correctly pull the TFTP capsule from the Subnet info.
    -- or --
    2.  Changing the "MAC Address" on the "Network" tab of the host when editing, before submitting, will also force it to recognize the change to the TFTP capsule for the subnet.   (Changing the IP Address does not appear to do so).
Comment 3 Bryan Kearney 2016-07-08 16:42:00 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 5 Ohad Levy 2016-11-30 09:24:15 EST
Satellite wont update the host tftp entry unless its in build mode, please make sure its enabled.

another easier workaround is simply to click on rebuild - which will trigger validation (including tftp) to check the host is ready for provisioning.

I believe this is a user error - please reopen i miss understood.

Note You need to log in before you can comment on or make changes to this bug.