Bug 1278666 - SELinux is preventing systemd-logind from 'unlink' accesses on the file scheduled.
SELinux is preventing systemd-logind from 'unlink' accesses on the file sched...
Status: CLOSED DUPLICATE of bug 1278659
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ab6753cb420c3d2c698cef9dbbf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 01:00 EST by Vinicius Reis
Modified: 2015-11-09 02:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 02:33:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vinicius Reis 2015-11-06 01:00:24 EST
Description of problem:
Scheduled a shutdown in terminal:
$ sudo shutdown -h 5:00
SELinux is preventing systemd-logind from 'unlink' accesses on the file scheduled.

*****  Plugin catchall (100. confidence) suggests   **************************

If você acredita que o systemd-logind deva ser permitido acesso de unlink em scheduled file  por default.
Then você precisa reportar este como um erro.
Você pode gerar um módulo de política local para permitir este acesso.
Do
permitir este acesso agora executando:
# grep systemd-logind /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_logind_t:s0
Target Context                system_u:object_r:init_var_run_t:s0
Target Objects                scheduled [ file ]
Source                        systemd-logind
Source Path                   systemd-logind
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64 #1 SMP Tue
                              Oct 27 04:29:56 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-06 03:58:55 BRST
Last Seen                     2015-11-06 03:58:55 BRST
Local ID                      1f60ace6-f6ea-4ee9-905c-93c3162a296e

Raw Audit Messages
type=AVC msg=audit(1446789535.153:654): avc:  denied  { unlink } for  pid=757 comm="systemd-logind" name="scheduled" dev="tmpfs" ino=279971 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:init_var_run_t:s0 tclass=file permissive=1


Hash: systemd-logind,systemd_logind_t,init_var_run_t,file,unlink

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-09 02:33:44 EST

*** This bug has been marked as a duplicate of bug 1278659 ***

Note You need to log in before you can comment on or make changes to this bug.