Bug 1278677 - python-debian unuseable on RHEL7 due to too old python-six
python-debian unuseable on RHEL7 due to too old python-six
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: python-debian (Show other bugs)
epel7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 02:09 EST by Jarek Polok
Modified: 2015-11-30 04:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 04:48:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarek Polok 2015-11-06 02:09:44 EST
Description of problem:

python-debian 0.1.27 requires python-six >= 1.4 

(https://packages.debian.org/sid/python-debian)

however the rpm does not specify this.

On RHEL7 python-six version is 1.3.0 .. to old for python-debian to function
properly.

Version-Release number of selected component (if applicable):

0.1.27-2.el7

How reproducible:

execute:

# python -c "from debian import deb822"

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/debian/deb822.py", line 1481, in <module>
    @six.add_metaclass(_ClassInitMeta)
AttributeError: 'module' object has no attribute 'add_metaclass'


Since python-six is system-provided on RHEL7 I believe for now the only workaround allowing to fix the problem would be to downgrade EPEL7 python-debian to version: 0.1.21-10.el7 (the 0.1.26 is also affected by same problem)
.. at least until RH decides to upgrade python-six on RHEL7 ..

Thanks for considering 

Jarek
Comment 1 Miroslav Suchý 2015-11-06 02:31:20 EST
Ah. Sorry.
However in RHEL7 there should be python-six-1.9.0-2.el7 and rhel 7.2 should be released soon.
Comment 2 Jarek Polok 2015-11-06 03:02:28 EST
Indeed, 7.2 will have python-six 1.9 - so I guess we can just wait for the release
to happen.

Thanks !

Jarek
Comment 3 Miroslav Suchý 2015-11-30 04:48:31 EST
rhel 7.2 is out with newer python-six.
Therefore I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.