Bug 1278707 - perl-SQL-SplitStatement: Failed test t/95-script.t
perl-SQL-SplitStatement: Failed test t/95-script.t
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-SQL-SplitStatement (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 04:00 EST by Jitka Plesnikova
Modified: 2015-11-21 21:24 EST (History)
3 users (show)

See Also:
Fixed In Version: perl-SQL-SplitStatement-1.00020-4.fc22 perl-SQL-SplitStatement-1.00020-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 10:24:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 108595 None None None Never

  None (edit)
Description Jitka Plesnikova 2015-11-06 04:00:23 EST
Description of problem:
Package perl-SQL-SplitStatement fails to build from source in rawhide.

Version-Release number of selected component (if applicable):
1.00020-3.fc24

Steps to Reproduce:
koji build --scratch f24 perl-SQL-SplitStatement-1.00020-3.fc24.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/perl-SQL-SplitStatement

Test failed with new perl-Getopt-Long 3.48

The similar command is called in the test 
$ perl -Ilib bin/sql-split -s --# -f --### -E t/data/create_table.sql 

Current result:
Unknown option: E
Usage:
        sql-split [ OPTIONS ] [ FILE(S) ]
        sql-split --man

Expected result:
perl -Ilib bin/sql-split -s --# -f --### -E t/data/create_table.sql
CREATE TABLE foo (
    foo_field_1 VARCHAR,
    foo_field_2 VARCHAR
)--#CREATE TABLE bar (
    bar_field_1 VARCHAR,
    bar_field_2 VARCHAR
)--#
Comment 1 Jitka Plesnikova 2015-11-06 04:13:16 EST
The temporary fix for the test is replacing using "-E" by "--empty"
Comment 2 Petr Pisar 2015-11-06 04:31:34 EST
Getopt-Long 3.48 fixed gnu_getopt compatibility mode. In that mode, it consider "--fo bar" as an option and a positional argument because gnut_getopt mode would requires "--foo=bar" syntax to make the "bar" a value of "foo" option.

If sql-split uses that mode, you have to call it as -E=t/data/create_table.sql. If not, it's probably a regressions in the Getopt::Long.
Comment 3 Jitka Plesnikova 2015-11-06 09:53:40 EST
If you add 'no_ignore_case' to Getopt::Long::Configure in bin/sql-split, it will fix the issue.

Due to the last changes in Getopt::Long 2.48, the bundling is disabled when gnu_compat is enabled. And it causes that single character options are not treated case-sensitive.

See:
https://metacpan.org/source/JV/Getopt-Long-2.48//lib/Getopt/Long.pm#L897
Comment 4 Emmanuel Seyman 2015-11-08 16:30:21 EST
Fixed in perl-SQL-Splitstatement 1.00020-4. I'll release this as an update once perl-Getopt-Long 2.48 hits stable in the other branches.
Comment 5 Jitka Plesnikova 2015-11-09 03:14:40 EST
Please add the fix also to rawhide. Currently, it is only in F23 branch.
Comment 6 Emmanuel Seyman 2015-11-09 03:48:26 EST
(In reply to Jitka Plesnikova from comment #5)
>
> Please add the fix also to rawhide. Currently, it is only in F23 branch.

My bad. I've cherry-picked the commit to master and the build is underway.
Comment 7 Petr Pisar 2015-11-09 03:55:38 EST
You can put to perl-Getopt-Long into built root overrides, build the perl-SQL-Splitstatment and then I can append the new perl-SQL-Splitstatment builds to perl-Getopt-Long errata so they will be released together.
Comment 8 Fedora Update System 2015-11-10 03:33:12 EST
perl-SQL-SplitStatement-1.00020-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-743dc4e9b5
Comment 9 Emmanuel Seyman 2015-11-10 03:42:27 EST
(In reply to Petr Pisar from comment #7)
> You can put to perl-Getopt-Long into built root overrides

After a good night's sleep, I realized this was unnecessary. Adding 'no_ignore_case' doesn't require the new Getopt-Long package.

I've built the updates and released them.
Comment 10 Fedora Update System 2015-11-10 19:50:46 EST
perl-SQL-SplitStatement-1.00020-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update perl-SQL-SplitStatement'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-743dc4e9b5
Comment 11 Fedora Update System 2015-11-10 21:23:15 EST
perl-SQL-SplitStatement-1.00020-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update perl-SQL-SplitStatement'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-75ef0d88a0
Comment 12 Fedora Update System 2015-11-20 10:24:35 EST
perl-SQL-SplitStatement-1.00020-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2015-11-21 21:24:20 EST
perl-SQL-SplitStatement-1.00020-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.