Bug 1278748 - SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'getattr' accesses on the file /usr/bin/epiphany.
SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'getattr' accesses on ...
Status: CLOSED DUPLICATE of bug 1276305
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-11-06 05:52 EST by Rubén Lledó
Modified: 2015-11-08 04:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-11-08 04:30:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: screenshot.png (49.62 KB, application/octet-stream)
2015-11-06 05:52 EST, Rubén Lledó
no flags Details

  None (edit)
Description Rubén Lledó 2015-11-06 05:52:39 EST
Description of problem:
Epiphany crashed when I clicked in a button to download a shell theme at http://gnome-look.org
SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'getattr' accesses on the file /usr/bin/epiphany.

*****  Plugin catchall (100. confidence) suggests   **************************

If cree que de manera predeterminada, abrt-hook-ccpp debería permitir acceso getattr sobre  epiphany file.     
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
permita el acceso momentáneamente executando:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:mozilla_exec_t:s0
Target Objects                /usr/bin/epiphany [ file ]
Source                        abrt-hook-ccpp
Source Path                   /usr/libexec/abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64 #1 SMP Tue
                              Oct 27 04:29:56 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-06 11:34:46 CET
Last Seen                     2015-11-06 11:34:46 CET
Local ID                      68b8791f-0989-4d87-bd4d-979cbda5dc2c

Raw Audit Messages
type=AVC msg=audit(1446806086.425:617): avc:  denied  { getattr } for  pid=23074 comm="abrt-hook-ccpp" path="/usr/bin/epiphany" dev="dm-0" ino=141718 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:mozilla_exec_t:s0 tclass=file permissive=0

type=SYSCALL msg=audit(1446806086.425:617): arch=x86_64 syscall=stat success=no exit=EACCES a0=5576aa128390 a1=7fff8c952650 a2=7fff8c952650 a3=5576aa128560 items=0 ppid=6 pid=23074 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-hook-ccpp exe=/usr/libexec/abrt-hook-ccpp subj=system_u:system_r:abrt_dump_oops_t:s0 key=(null)

Hash: abrt-hook-ccpp,abrt_dump_oops_t,mozilla_exec_t,file,getattr

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64
type:           libreport
Comment 1 Rubén Lledó 2015-11-06 05:52:44 EST
Created attachment 1090592 [details]
File: screenshot.png
Comment 2 Miroslav Grepl 2015-11-08 04:30:03 EST

*** This bug has been marked as a duplicate of bug 1276305 ***

Note You need to log in before you can comment on or make changes to this bug.