Bug 1278777 - invalid filename is used in file context pattern for pegasus configuration file
invalid filename is used in file context pattern for pegasus configuration file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.2
All Linux
low Severity low
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 06:49 EST by Milos Malik
Modified: 2016-11-03 22:24 EDT (History)
6 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-68.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278771
Environment:
Last Closed: 2016-11-03 22:24:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2015-11-06 06:49:34 EST
+++ This bug was initially created as a clone of Bug #1278771 +++

Description of problem:
# semanage fcontext -l | grep /etc/Pegasus
/etc/Pegasus(/.*)?                                 all files          system_u:object_r:pegasus_conf_t:s0 
/etc/Pegasus/pegasus_current\.conf                 all files          system_u:object_r:pegasus_data_t:s0 
#

But the service does not create / use any file called pegasus_current.conf. The service creates / uses a file called cimserver_current.conf.

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-60.el7.noarch
selinux-policy-devel-3.13.1-60.el7.noarch
selinux-policy-doc-3.13.1-60.el7.noarch
selinux-policy-minimum-3.13.1-60.el7.noarch
selinux-policy-mls-3.13.1-60.el7.noarch
selinux-policy-sandbox-3.13.1-60.el7.noarch
selinux-policy-targeted-3.13.1-60.el7.noarch
tog-pegasus-2.14.1-3.el7.x86_64
tog-pegasus-devel-2.14.1-3.el7.x86_64
tog-pegasus-libs-2.14.1-3.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# service tog-pegasus start
Redirecting to /bin/systemctl start  tog-pegasus.service
# service tog-pegasus status
Redirecting to /bin/systemctl status  tog-pegasus.service
● tog-pegasus.service - OpenPegasus CIM Server
   Loaded: loaded (/usr/lib/systemd/system/tog-pegasus.service; disabled; vendor preset: disabled)
   Active: active (running) since Fri 2015-11-06 12:03:10 CET; 3s ago
  Process: 21133 ExecStart=/usr/sbin/cimserver (code=exited, status=0/SUCCESS)
  Process: 21128 ExecStartPre=/usr/share/Pegasus/scripts/generate-certs (code=exited, status=0/SUCCESS)
 Main PID: 21137 (cimserver)
   CGroup: /system.slice/tog-pegasus.service
           └─21137 /usr/sbin/cimserver

Nov 06 12:03:10 rhel72.localdomain systemd[1]: Starting OpenPegasus CIM Serv....
Nov 06 12:03:10 rhel72.localdomain systemd[1]: Started OpenPegasus CIM Server.
Hint: Some lines were ellipsized, use -l to show in full.
# service tog-pegasus stop
Redirecting to /bin/systemctl stop  tog-pegasus.service
# restorecon -Rv /etc/Pegasus/
restorecon reset /etc/Pegasus/cimserver_current.conf context system_u:object_r:pegasus_data_t:s0->system_u:object_r:pegasus_conf_t:s0
# restorecon -Rv /etc/Pegasus/
#

Actual results:
 * the file context pattern contains an invalid filename

Expected results:
 * the file context pattern contains a correct filename
Comment 2 Mike McCune 2016-03-28 18:59:28 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 errata-xmlrpc 2016-11-03 22:24:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Note You need to log in before you can comment on or make changes to this bug.