Bug 1278796 - logshifter stops sending logs to syslog
logshifter stops sending logs to syslog
Status: CLOSED DUPLICATE of bug 1284900
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Luke Meyer
Depends On: 1284900
Blocks: 1273542
  Show dependency treegraph
Reported: 2015-11-06 07:52 EST by Evgheni Dereveanchin
Modified: 2016-09-29 22:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-11-26 08:02:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2061963 None None None Never

  None (edit)
Description Evgheni Dereveanchin 2015-11-06 07:52:18 EST
Description of problem:
in certain conditions, a logshifter process configured for syslog stops sending logs. It reads the pipe yet no messages are received on syslog side. This causes major issues with gear logging as the gear needs a restart to fix this

Version-Release number of selected component (if applicable):

How reproducible:
sometimes with gears having high log volume

Steps to Reproduce:
no clear reproducer at the moment. The gear can run for months before this issue reoccurs.
Comment 8 Dan Mace 2015-11-10 10:21:14 EST
To continue diagnosing this, we'll need either:

1. Steps to reproduce.
2. A stack dump from logshifter while it's observed to be in a stalled state. This can be obtained by issuing a SIGABRT to the logshifter process.
Comment 17 Josep 'Pep' Turro Mauri 2015-11-26 08:02:11 EST
Investigation of this bug revealed that the root cause is not in logshifter. It appears to be a problem in the kernel's epoll facility. This is being tracked in a separate bug report for the kernel (bug 1284900).

The resolution of the kernel bug should address the problem reported in here for logshifter, so I'm closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 1284900 ***

Note You need to log in before you can comment on or make changes to this bug.