Bug 127884 - panic: temporary file seek
panic: temporary file seek
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mailx (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-07-14 17:25 EDT by John Reiser
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 09:02:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2004-07-14 17:25:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
If root tries to look at its local mail (from updatedb, for instance),
then it takes about a minute, and panics.

Version-Release number of selected component (if applicable):
mailx-8.1.1-33

How reproducible:
Always

Steps to Reproduce:
1. Fresh graphical install FC3test1 from CD-ROM; finish firstboot.
2. Wait until updatedb runs the first time.
3. Login as root, then try to read mail.
    

Actual Results:  [root@fc3test1 root]# mail
Mail version 8.1 6/6/93.  Type ? for help.
"/var/spool/mail/root": 3 messages 3 new
>N  1 root@localhost.local  Wed Jul 14 03:27 -13259/251558593
fseek: Invalid argument
panic: temporary file seek
Aborted


Expected Results:  Normal examination of received messages.

Additional info:

The tail of "strace -f mail" says
-----
write(1, "Mail version 8.1 6/6/93.  Type ?"..., 43) = 43
write(1, "\"/var/spool/mail/root\": 3 messag"..., 41) = 41
write(4, "beling /taroon/sbin/cardmgr from"..., 3966) = 3966
_llseek(5, 0, [0], SEEK_SET)            = 0
read(5, "From root@localhost.localdomain "..., 4096) = 4096
_llseek(5, 4096, [4096], SEEK_SET)      = 0
_llseek(5, 4096, [4096], SEEK_SET)      = 0
_llseek(5, 4096, [4096], SEEK_SET)      = 0
_llseek(5, 4096, [4096], SEEK_SET)      = 0
_llseek(5, 4096, [4096], SEEK_SET)      = 0
write(1, ">N  1 root@localhost.local  Wed "..., 62) = 62
_llseek(5, 18446744073692672000, 0xfee37abc, SEEK_SET) = -1 EINVAL
(Invalid argument)
dup(2)                                  = 3
fcntl64(3, F_GETFL)                     = 0x8001 (flags
O_WRONLY|O_LARGEFILE)
close(3)                                = 0
write(2, "fseek: Invalid argument\n", 24fseek: Invalid argument
) = 24
write(2, "panic: ", 7panic: )                  = 7
write(2, "temporary file seek", 19temporary file seek)     = 19
write(2, "\n", 1
)                       = 1
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(15796, 15796, SIGABRT)           = 0
--- SIGABRT (Aborted) @ 0 (0) ---
+++ killed by SIGABRT +++
-----
Comment 1 Ivana Varekova 2004-11-11 08:35:25 EST
Thank your for your notice, 
I can't reproduce this bug, pleas attach the file /var/spool/mail/root
which caused this problem.
IV  
Comment 2 Ivana Varekova 2004-12-08 09:02:28 EST
I can't reproduce this bug until I have the file /var/spool/mail/root
which caused the problem.
Ivana Varekova
Comment 3 Simon Tutek 2005-03-10 07:17:42 EST
I have same problem.

The root mail file is 2.5G, so I wouldn't upload that.

I renamed the file and recreated /var/spool/mail/root - sems the
problem is gone.

Can the mail file be too large?

Note You need to log in before you can comment on or make changes to this bug.