Bug 1278847 - libvirtd crashes in libxl if libvirt-daemon-driver-vbox is installed due to a SIGCHLD handling conflict
libvirtd crashes in libxl if libvirt-daemon-driver-vbox is installed due to a...
Status: NEW
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-11-06 09:35 EST by Ting-Wei Lan
Modified: 2017-05-03 14:31 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ting-Wei Lan 2015-11-06 09:35:37 EST
Description of problem:
If both libvirt-daemon-driver-xen and libvirt-daemon-driver-vbox are installed, libvirtd crashes when an user connects to it.
This problem was reported by other people several months ago, but it is still not fixed:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install libvirt-daemon-driver-xen and libvirt-daemon-driver-vbox.
2. Boot the system as a Xen dom0.
3. Run virsh -c xen:///

Actual results:
libvirtd[19002]: libvirtd: libxl_fork.c:350: sigchld_installhandler_core: Assertion `((void)"application must negotiate with libxl about SIGCHLD", !(sigchld_saved_action.sa_flags & 4) && (sigchld_saved_action.__sigaction_handler.sa_handler == ((__sighandler_t) 0) || sigchld_saved_action.__sigaction_handler.sa_handler == ((__sighandler_t) 1)))' failed.
systemd[1]: libvirtd.service: Main process exited, code=killed, status=6/ABRT
systemd[1]: libvirtd.service: Unit entered failed state.
systemd[1]: libvirtd.service: Failed with result 'signal'.

Expected results:
No crash

Additional info:
Removing /usr/lib64/libvirt/connection-driver/libvirt_driver_vbox.so fixes the problem.
Comment 1 Cole Robinson 2015-11-10 15:00:51 EST
There was an older bug about this crash as well, but the culprit wasn't identified:

Comment 2 Panormitis Petrou 2016-01-19 02:49:22 EST
I can confirm this bug too.
I had to do: rpm -e --nodeps libvirt-daemon-driver-vbox
Then libvirtd worked.

When I tried to remove it via "dnf remove libvirt-daemon-driver-vbox" DNF wanted to remove libvirt too, so I did "rpm -e --nodeps libvirt-daemon-driver-vbox"

I don't see why libvirt needs libvirt-daemon-driver-vbox. Wrong dependency issue perhaps?
Comment 3 Cole Robinson 2016-01-19 10:34:31 EST
'libvirt' is just a back compatible meta-package that pulls in *all* libvirt* packages. You can safely remove it. If you want xen bits all you really need is libvirt-client, libvirt-daemon, libvirt-daemon-driver-xen
Comment 4 Panormitis Petrou 2016-01-19 17:00:06 EST
(In reply to Cole Robinson from comment #3)

I see, thanks for pointing that out.
Comment 5 Cole Robinson 2016-04-26 17:31:36 EDT
Note I did revive the thread in november and one the xen devs added more info:


But I still don't think this is resolved anywhere
Comment 6 Fedora End Of Life 2016-11-24 08:08:35 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Ting-Wei Lan 2016-11-24 08:12:13 EST
It is still broken on Fedora 25.

Note You need to log in before you can comment on or make changes to this bug.