Bug 127886 - Regex characters in devlabel uuids break things
Regex characters in devlabel uuids break things
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: devlabel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-14 17:45 EDT by Brandon Black
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 0.48.03-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-21 04:27:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brandon Black 2004-07-14 17:45:05 EDT
Hitachi's 9980 enterprise storage arrays use the string
"HITACHIOPEN-V*10" as part of the scsi vendor id stuff.  As a result,
devlabel breaks when trying to use it on Hitachi 9980s, because the
version of devlabel included in RHEL3 is outdated and doesn't include
the fix for this issue:

Steps to Reproduce:
[root@marcelo2 redhat]# devlabel printid -d /dev/sda
S83.1:4849544143484920523435304139373330303141HITACHIOPEN-V*10
[root@marcelo2 redhat]# devlabel printid -d /dev/sda5
S83.1:4849544143484920523435304139373330303141HITACHIOPEN-V*10sector126-400018499
[root@marcelo2 redhat]# devlabel add -d /dev/sda5 -s /dev/hds_lun0_p5
 
Failure.
The device you are trying to add to devlabel does not show up in
/proc/partitions.
[root@marcelo2 redhat]# grep sda5 /proc/partitions
   8     5  200009187 sda5 56 288 688 30 0 0 0 0 0 30 30

This is the exact same bug as Bug# 113107, which was filed against
Fedora.  I only opened a new bug because this is RHEL not Fedora, and
it's 6 months down the road since that bug was last commented on (Gary
fixed devlabel itself, but RHEL is still using an outdated version
which doesn't have the fix), feel free to mark this as a dupe or
change that bug's product to RHEL, or whatever way is "correct" way to
handle that.
Comment 5 Karel Zak 2005-07-21 04:25:03 EDT
Hmm.. there was version update in RHEL3-U4 (see errata RHBA-2004:514) and this
problem has been fixed by upstream. It seems someone forgot close this report in
bugzilla.

3.0E  	        0.41.01-1
3.0E-U1 	0.42.05-2.1
3.0E-U4 	0.48.03-6
3.0E-U5 	0.48.03-10

It should be fixed in the current release. Closing...

Note You need to log in before you can comment on or make changes to this bug.