Bug 1278885 - black/absent widgetry only with libreoffice-gtk3 installed
black/absent widgetry only with libreoffice-gtk3 installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 11:26 EST by Dr. David Alan Gilbert
Modified: 2015-12-14 05:28 EST (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-5.0.3.2-5.fc23 libreoffice-5.0.3.2-12.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 05:20:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of presentation showing missing/black areas to the right/bottom (209.04 KB, image/png)
2015-11-06 11:26 EST, Dr. David Alan Gilbert
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Document Foundation 93373 None None None Never

  None (edit)
Description Dr. David Alan Gilbert 2015-11-06 11:26:09 EST
Created attachment 1090721 [details]
Screenshot of presentation showing missing/black areas to the right/bottom

Description of problem:
See attached screen grab; the black area to the right/bottom - that renders correctly if I uninstall the libreoffice-gtk3 package

Version-Release number of selected component (if applicable):
  libreoffice-gtk3.x86_64 1:5.0.3.1-1.fc23          

How reproducible:
100%

Steps to Reproduce:
1. install libreoffice-gtk3
2. Open presentation
3.

Actual results:
Black areas to the right/bottom of the screen rather than widgets

Expected results:
All my widgetry

Additional info:
t530/1920x1080 display (x2 one internal, one external); running xfce.
Comment 1 Caolan McNamara 2015-11-12 05:52:38 EST
Hopefully what I've now fixed is the same problem as this. The above looks cut off, while in my case I sporadically get an impress window which is larger than its contents, i.e. rendered correctly but at the wrong size. We can find out if they have the same root cause when the build it complete
Comment 2 Dr. David Alan Gilbert 2015-12-02 15:13:53 EST
This still happens for me with 

libreoffice-gtk3-5.0.3.2-7.fc23.x86_64

(If anything it's worse - I'm only seeing a small square at the top left now opening a .doc, where as before I'd just lost the widgetry to the left.

Dave
Comment 3 Fedora Update System 2015-12-11 04:33:12 EST
libreoffice-5.0.3.2-12.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-73116e9d95
Comment 4 Fedora Update System 2015-12-11 22:23:18 EST
libreoffice-5.0.3.2-12.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update libreoffice'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-73116e9d95
Comment 5 Fedora Update System 2015-12-14 05:20:15 EST
libreoffice-5.0.3.2-12.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Dr. David Alan Gilbert 2015-12-14 05:28:53 EST
I can confirm with the -12.fc23 version I no longer get the display corruption.

Note I did hit (an unreapatable???) segv on quit:
https://retrace.fedoraproject.org/faf/reports/bthash/495eefbe0f543035fb07d5f649defb2e3856779e/

Dave

Note You need to log in before you can comment on or make changes to this bug.