Bug 1278893 - Cannot view more than 20 hosts associated with an activation key
Cannot view more than 20 hosts associated with an activation key
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.3
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Walden Raines
Adam Ruzicka
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1317008
  Show dependency treegraph
 
Reported: 2015-11-06 11:51 EST by Stuart Auchterlonie
Modified: 2016-07-27 07:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:35:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2137241 None None None 2016-01-24 17:27 EST
Foreman Issue Tracker 14337 None None None 2016-04-26 12:57 EDT

  None (edit)
Description Stuart Auchterlonie 2015-11-06 11:51:42 EST
Description of problem:

If you try to review the hosts associated with an activation
key, you can only view 20 hosts, not the full number associated
with that key.

The listing of consumed entitlements is correct.
ie. 40 out of unlimited
when looking at the listing of activation keys (Content > Activation Keys)

But when you view the activation key, then navigate to
Associations > Content Hosts, only 20 hosts are listed, with no way
of navigating to the remaining hosts.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Subscribe more than 20 hosts to satellite via an activation key
2. Navigate to Content > Activation Keys.
3. Select the activation key with more than 20 consumed entitlements
4. Navigate to Association > Content Hosts tab

Actual results:

Only 20 hosts are shown, with no way of navigating to the others

Expected results:

Some way of navigating to hosts other than the first 20

Additional info:
Comment 3 Walden Raines 2016-03-23 17:00:07 EDT
Created redmine issue http://projects.theforeman.org/issues/14337 from this bug
Comment 4 Bryan Kearney 2016-03-23 18:03:43 EDT
Upstream bug component is Content Management
Comment 5 Walden Raines 2016-03-23 19:39:14 EDT
PR - https://github.com/Katello/katello/pull/5913
Comment 6 Bryan Kearney 2016-04-05 14:03:48 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14337 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|9aa09d8bc905f4b000bf2e261be646079edbe8eb.
Comment 7 Adam Ruzicka 2016-06-28 05:58:49 EDT
VERIFIED.
Satellite 6.2 GA 17.0
katello-3.0.0-8.el7sat.noarch

Followed instructions from comment #0, at first 20 hosts are shown, more are loaded on-demand when one scrolls to the bottom of the table.
Comment 8 Bryan Kearney 2016-07-27 07:35:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.