Bug 1278909 - Error during Content View publish or promote "Action not allowed for the default capsule"
Error during Content View publish or promote "Action not allowed for the defa...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.4
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Chris Duryee
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 12:49 EST by Mike McCune
Modified: 2016-10-13 12:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-13 12:06:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2015-11-06 12:49:00 EST
This is caused by the Capsule having the '--pulp-master true' flag passed during installation, which enables the "Pulp" feature enabled on the Capsule.

This feature is for the Satellite only and should never be enabled on a Capsule. We need to block/remove this option from the capsule-installer.


** WORKAROUND **

If the user is experiencing this error message they should 

1) execute on each capsule:

# capsule-installer --pulp-master false

2) Login to the Satellite UI and navigate to Infrastructure -> Capsules

3) Click "Refresh Features" on each Capsule.
Comment 2 Stephen Benjamin 2016-10-13 12:06:16 EDT
Looks to be fixed.

Note You need to log in before you can comment on or make changes to this bug.