Bug 1278925 - Compute deployment fails due to keystone unauthorized error
Compute deployment fails due to keystone unauthorized error
Status: CLOSED DUPLICATE of bug 1258614
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
All Linux
high Severity urgent
: ---
: 7.0 (Kilo)
Assigned To: Mike Burns
yeylon@redhat.com
:
Depends On:
Blocks: 1261979
  Show dependency treegraph
 
Reported: 2015-11-06 13:46 EST by Chris Dearborn
Modified: 2016-04-18 02:58 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 10:27:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from "journalctl -u os-collect-config" (102.97 KB, application/x-gzip)
2015-11-06 13:46 EST, Chris Dearborn
no flags Details

  None (edit)
Description Chris Dearborn 2015-11-06 13:46:45 EST
Created attachment 1090770 [details]
Output from "journalctl -u os-collect-config"

Description of problem:
Deployment of OpenStack with OSP Director fails when deploying with 3 or more computes.  The error is:

Stack failed with status: Resource CREATE failed: Error: resources.ControllerNod                                             esPostDeployment.resources.ControllerOvercloudServicesDeployment_Step6.resources                                             [0]: Deployment to server failed: deploy_status_code: Deployment exited with non                                             -zero status code: 6
ERROR: openstack Heat Stack create failed.


“heat resource-list overcloud -n 5| grep FAIL” yields:
| ControllerNodesPostDeployment               | 10b3c635-09ec-4124-9889-d7c9424a3c31          | OS::TripleO::ControllerPostDeployment             | CREATE_FAILED   | 2015-11-05T16:50:42Z |                                             |
| ControllerOvercloudServicesDeployment_Step6 | 6d786640-8ee6-4f55-bb5b-29ad8d4a4be0          | OS::Heat::StructuredDeployments                   | CREATE_FAILED   | 2015-11-05T17:06:20Z | ControllerNodesPostDeployment               |
| 0                                           | 3ac44662-2d47-422e-bdd4-43f334173f51          | OS::Heat::StructuredDeployment                    | CREATE_FAILED   | 2015-11-05T17:15:55Z | ControllerOvercloudServicesDeployment_Step6 |


“sudo journalctl –u os-collect-config” on controller0 contains the following error (the full output is attached):
31mWarning: Scope(Swift::Storage::Server[6000]): The default outgoing_chmod set to 0644 may yield in error prone directories and will be changed in a later release.\u001b[0m\n\u001b[1;31mError: Received error response from Keystone server at http://192.168.120.73:35357/v3/domains: Unauthorized\u001b[0m\n\u001b[1;31mError: /Stage[main]/Heat::Keystone::Domain/Heat_domain_id_setter[heat_domain_id]/ensure: change from absent to present failed: Received error response from Keystone server at http://192.168.120.73:35357/v3/domains: Unauthorized\u001b[0m\n", "deploy_status_code": 6}


Version-Release number of selected component (if applicable):
OSP 7

How reproducible:
Deploy with 3 or more compute nodes.

Steps to Reproduce:
1. Deploy with 3 or more compute nodes.

Actual results:
Deployment fails.

Expected results:
Deployment succeeds.

Additional info:
Comment 2 James Slagle 2015-11-06 21:35:52 EST
Hi, this does appear related to https://bugzilla.redhat.com/show_bug.cgi?id=1258614

what version of openstack-tripleo-heat-templates do you have on the undercloud and what version of openstack-puppet-modules do you have on the overcloud nodes?
Comment 3 Chris Dearborn 2015-11-09 11:50:48 EST
On the undercloud: openstack-tripleo-heat-templates-0.8.6-71.el7ost.noarch

On controller0: openstack-puppet-modules-2015.1.8-21.el7ost.noarch
Comment 4 Chris Dearborn 2015-11-23 10:17:13 EST
I tested the fix with the latest bits and the supplied openstack-puppet-modules-2015.1.8-28.el7ost.noarch.rpm, and it is working great.

Please feel free to mark this bug as fixed/dupe as needed.

Thanks!
Comment 5 Mike Burns 2015-11-23 10:27:50 EST

*** This bug has been marked as a duplicate of bug 1258614 ***

Note You need to log in before you can comment on or make changes to this bug.