Bug 1278988 - taskomatic/reposync silently drops any overlapping jobs
taskomatic/reposync silently drops any overlapping jobs
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.4
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Dobes
Red Hat Satellite QA List
:
Depends On:
Blocks: space27
  Show dependency treegraph
 
Reported: 2015-11-06 18:17 EST by Thomas Eriksson
Modified: 2017-09-28 14:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-01 05:19:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Eriksson 2015-11-06 18:17:41 EST
Description of problem: Scheduled reposync jobs that overlap in time will be silently dropped with any logging.


Version-Release number of selected component (if applicable): 2.4 upgraded from 2.3


How reproducible: Every time


Steps to Reproduce:
1. Schedule two reposync jobs at the same time or just so that the first one has not completed before the next job is supposed to be started.

Actual results: The second job will not be queued up or run. There will be no trace of the fact that it did not run in the logs.


Expected results: Second job should be queued up and run once the first finished.
At the very least, the failure should be logged.

Additional info: This was working in the 2.3 release.
Comment 1 Jan Dobes 2015-11-19 11:46:58 EST
related PR:

https://github.com/spacewalkproject/spacewalk/pull/312
Comment 2 Thomas Eriksson 2015-11-19 21:00:00 EST
Yes, that looks like the exact issue.

Any chance of seeing updated 2.4 packages, or will it be deferred to 2.5?
Comment 3 Tomas Lestach 2015-11-27 04:50:12 EST
Patch was accepted to Spacewalk as ...

spacewalk.git: ac450714588297a5198af3e5d819fd5004e3813b
Comment 4 Tomas Lestach 2015-11-27 11:29:53 EST
spacewalk-java-2.4.79-1 should appear in the Spacewalk 2.4 repositories with the fix.
Comment 5 Eric Herget 2017-09-28 14:09:17 EDT
This BZ closed some time during 2.5, 2.6 or 2.7.  Adding to 2.7 tracking bug.

Note You need to log in before you can comment on or make changes to this bug.