Bug 12790 - kernel panic when booting
kernel panic when booting
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Depends On:
  Show dependency treegraph
Reported: 2000-06-21 14:58 EDT by jctonnison
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-12-14 18:59:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jctonnison 2000-06-21 14:58:50 EDT
I built a computer with the following hardware:

     Athlon 700 MHz
     Asus K7V mobo w/o audio
     128 Mb PC133 from Mushkin (run at 100 MHz)
     Diamond Viper V550 video card
     300 W Sparkle power supply
     50X Asus CD drive
     Western Digital 13.6 GB hard drive
     SoundBlaster Live!
     3COM/USR 2977 56K PCI modem

     I loaded RH6.2, and the installation went fine. I booted the 
computer, and about 1 sec after the lilo prompt the computer crashed,
giving the following error message:

     Kernel panic: Attempted to kill the idle task!
     In swapper task - not syncing

The boot screen would then freeze and nothing else would happen.
I had a copy of Storm Linux 2000, Rain release. That OS installed and
ran on my machine, no problem.
     Next I called tech support. I received the following suggestions 
(none of which worked):

     boot from floppy;
     install the LILO boot record on the first sector of the boot
     get a new installer disk from RH/support/errata:
           boot-20000407.img and update-disk-20000407.img

I also pulled the modem and sound card; UNDERclocked the CPU; did a
Custom (16M for \boot and 256M for Linux Swap) and Workstation install, 
and my machine did not boot. The last tech I spoke with ran out of ideas, 
and suggested I report this error to you.

     Thank you,
     James Tonnison
Comment 1 jonesy 2000-07-06 10:02:10 EDT
I, too, have the same problem with a similar architecture...

Athlon 700 processor;
Voodoo3 3000 PCI graphics card;
128MB 200MHz RAM;
USR 56k External Faxmodem;
Creative Labs CD-RW
DVD-rom drive (don't know the manu- it's a new box)
30GB Western Digital Hard drive

Some background - 
I got the EXACT same error after several attempts at installing 6.2 
professional.  Successfully installed 6.1 standard, but upgrading to 6.2 
produced the same error.  Tried several different configuration options and 
BIOS configurations, but to no avail.

Finally installed 6.1, had fdisk create an empty dos partition table, and 
installed windows to look at the hardware.  The hard drive controller is 
a 'dual' hard drive controller and also says '(dual fifo)'.  I'll get the model 
when I get home today.
Comment 2 Need Real Name 2000-08-04 11:32:46 EDT
See also bug 14304.
Possible cause :
The function disable_serial_nr() in /include/asm_i386/processor.h is not 
present in BOOT (install) kernel, but a kernel (Intel based) with this call 
(CONFIG_X86_PN_OFF in kernel source) is installed during the install process, 
both on repair floppy and boot.

Workaround :
- Boot on CD with "linux rescue"
- mount the partition where is the faulty kernel (mkdir /mnt/a; 
mount /dev/hda1 /mnt/a)
- cp /mnt/source/dosutils/autoboot/vmlinuz /mnt/a/boot/vmlinuz-2.2.14-5.0
- umount /mnt/a
- Ctlr Alt Del. There will be many errors from modules (cdrom, network ...)
- Install kernel sources and recompile a good kernel (do not disable processor 
serial number!). It is better to install kernel sources the first time since 
cdrom may not be accessible.

It is quite porky, but it works.
Asus A7V
AMD TBird 800

Comment 3 Alan Cox 2000-08-08 18:08:17 EDT
The errata kernel and also 6.9.5 should fix this.
Comment 4 Alan Cox 2002-12-14 18:59:42 EST
Long fixed, just tidying

Note You need to log in before you can comment on or make changes to this bug.