Bug 1279017 - Ignoring exclude filters
Ignoring exclude filters
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 02:36 EST by Yajo
Modified: 2016-01-11 03:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 03:16:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yajo 2015-11-07 02:36:17 EST
Description of problem:
gnome-software keeps asking me to update packages that I have excluded in the .repo file.


Version-Release number of selected component (if applicable):
dnf-1.1.3-1.fc22.noarch
gnome-software-3.16.6-1.fc22.x86_64



How reproducible:
Always.


Steps to Reproduce:
1. sudo nano /etc/yum.repos.d/rpmfusion-nonfree-updates.repo
2. Add exclude=*nvidia* to [rpmfusion-nonfree-updates] section
3. Run dnf update. No updates.
4. Run gnome-software update. It wants to update nvidia drivers.


Actual results:
Asking me to update excluded packages from that repository.


Expected results:
Do not update that, like dnf does.


Additional info:
I know you do not support nvidia driver, but this seems Fedora's bug.
Comment 1 Richard Hughes 2016-01-08 04:30:06 EST
Fixed in F23, right?
Comment 2 Yajo 2016-01-11 03:16:06 EST
Right :)

Note You need to log in before you can comment on or make changes to this bug.