Bug 1279033 - KDE: Drag and drop not working
KDE: Drag and drop not working
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: dolphin (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Vrátil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 05:27 EST by Matthias
Modified: 2016-12-20 10:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 10:28:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias 2015-11-07 05:27:08 EST
Description of problem:
After upgrade from F22 to F23 drag and drop does not work under KDE/ Dolphin.


Version-Release number of selected component (if applicable):
Fully updated system (to "updates-testing").

Dolphin gives these versions:
Dolphin: Version 15.08.1
KDE Frameworks 5.15.0
Qt 5.5.1, compiled against 5.5.0

How reproducible:
Always

Steps to Reproduce:
1. Mark one or multiple files/ folders
2. Try to drag them into an open Firefox or Chrome window with Google Drive or Google Photos open
3. It is not possible to drop the files and upload them. This worked in F22.

Actual results:
Dropping of files in Firefox and Chrome not possible

Expected results:
Can drop the files, same as in F22.

Additional info:
Comment 1 Matthias 2015-11-10 02:15:40 EST
After latest updates (10.Nov.15) drag and drop works in Firefox.

It is still not working in Chrome. But I guess that is a issue for Google, not for Fedora. Any idea why drag and drop stopped working in F23 when it was working in F22?
Comment 2 Matthias 2015-11-14 01:32:06 EST
Another update:

Updated to KDE Frameworks 5.16.0 from updates-testing.

Drag and drop from Dolphin to Chrome still doesn't work.

However, I found that I can drag files and folders from Konqueror (if used as file manager) to Chrome (e.g. Google Drive or Google Photos).

So Konqueror works as expected, but Dolphin does not.
Comment 3 Fedora End Of Life 2016-11-24 08:09:50 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2016-12-20 10:28:48 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.