Bug 127905 - up2date (and rhn_register) barf if proxy user or password are numeric
up2date (and rhn_register) barf if proxy user or password are numeric
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks: 120092 up2date-rhel2.1-u6 130798
  Show dependency treegraph
 
Reported: 2004-07-15 03:00 EDT by Alexandre Oliva
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 12:35:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-07-15 03:00:22 EDT
up2date-2.9.3-1.2.1AS and rhn_register-2.9.3-1.2.1AS barf if proxy
user or proxy password in the config file are entirely numeric.

I suppose we could use the default or previous value to tell whether
the value is to be converted to int or remain as a string.  E.g., if
the key is already defined, with a value that is an integer, we
convert the new value to integer.  If it is already defined to a
string, we leave the new value alone.  Otherwise, we may apply the
current heuristics, just to make sure we're not unexpectedly changing
behavior.
Comment 2 Clifford Perry 2006-04-03 12:35:27 EDT
Since Enterprise Linux 2.1 has gone into maintenance mode, this bug will not be
fixed in 2.1. This though has been fixed in Enterprise Linux 3 and 4 - see bugs:

145554
159856

Regards,
Clifford. 

Note You need to log in before you can comment on or make changes to this bug.