Bug 1279050 - SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr/lib/systemd/systemd-journald.
SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr...
Status: CLOSED DUPLICATE of bug 1276305
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e96be6af071c0f148f3e356df08...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 08:32 EST by Marcel Ziswiler
Modified: 2015-11-08 04:29 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-08 04:29:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Ziswiler 2015-11-07 08:32:03 EST
Description of problem:
Might have involved a suspend/resume cycle.
SELinux is preventing abrt-hook-ccpp from 'getattr' accesses on the file /usr/lib/systemd/systemd-journald.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed getattr access on the systemd-journald file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                system_u:object_r:syslogd_exec_t:s0
Target Objects                /usr/lib/systemd/systemd-journald [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           systemd-222-8.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-152.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64 #1 SMP Tue
                              Oct 27 04:29:56 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-05 16:48:53 CET
Last Seen                     2015-11-05 16:48:53 CET
Local ID                      7b1493f3-6b42-44f7-9a86-1b2d4b2b7b75

Raw Audit Messages
type=AVC msg=audit(1446738533.194:2472): avc:  denied  { getattr } for  pid=29723 comm="abrt-hook-ccpp" path="/usr/lib/systemd/systemd-journald" dev="dm-1" ino=925577 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=system_u:object_r:syslogd_exec_t:s0 tclass=file permissive=0


Hash: abrt-hook-ccpp,abrt_dump_oops_t,syslogd_exec_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64
type:           libreport

Potential duplicate: bug 1277392
Comment 1 Denis Otugo 2015-11-07 19:13:13 EST
Description of problem:
i have no idea, but i know it is reptitive and has happened 5 times in the SElinux log.
I Use gnome 3.18.1 On f23

Version-Release number of selected component:
selinux-policy-3.13.1-152.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.i686
type:           libreport
Comment 2 Miroslav Grepl 2015-11-08 04:29:54 EST

*** This bug has been marked as a duplicate of bug 1276305 ***

Note You need to log in before you can comment on or make changes to this bug.