Bug 1279057 - There is no way to set the user avatar / face icon.
There is no way to set the user avatar / face icon.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-baseapps (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: FutureFeature
Depends On: plasma-user-manager
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 09:51 EST by 3ndymion
Modified: 2016-11-18 10:09 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 23:22:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A pic showing that the user avatar settings menu still exists, & works. (268.07 KB, image/png)
2016-01-04 03:52 EST, 3ndymion
no flags Details
A pic showing the system settings & its incorrect "Account details" option. (436.69 KB, image/png)
2016-01-04 04:02 EST, 3ndymion
no flags Details
A pic showing the new program's rejection (520.12 KB, image/png)
2016-01-05 23:54 EST, 3ndymion
no flags Details

  None (edit)
Description 3ndymion 2015-11-07 09:51:33 EST
Description of problem:
There is no way to set the user's face icon.  It is nowhere to be found in the system settings, & clicking on the avatar next to the user name in the panel's application launcher does absolutely nothing.

Version-Release number of selected component (if applicable):
Fedora 23 Stable

How reproducible:
Always

Steps to Reproduce:
1. Search for an option to do this in system settings.  FAIL
2. Click on the avatar next to user name in the panel's application launcher.  FAIL
3.

Actual results:
Clicking on the avatar in the application launcher does absolutely nothing.

Expected results:
Clicking on the avatar in the application launcher should give the option to change the user's avatar / face icon.

Additional info:
Fedora 23 Stable  Installed from net-install image with no problems
Comment 1 Rex Dieter 2015-11-07 12:49:55 EST
True, neither of those are implemented for plasma5/kf5 yet (marking FutureFeature)


There is currently on kde4 based UI provided by kdepasswd, accessible via:
kcmshell4 useraccount
Comment 2 Elia Devito 2015-12-04 13:40:33 EST
It should be fine as replacemnt

https://quickgit.kde.org/?p=user-manager.git
Comment 3 Rex Dieter 2015-12-04 13:43:19 EST
Thanks, I've been meaning to get that packaged, now we have more incentive.
Comment 4 Elia Devito 2015-12-04 15:57:56 EST
I have packaged it:

https://copr.fedoraproject.org/coprs/scorpionit/user-manager/
Comment 5 Rex Dieter 2015-12-08 15:45:03 EST
Thanks, submitted review at bug #1289738 , initially based on that copr content
Comment 6 3ndymion 2016-01-04 03:52 EST
Created attachment 1111401 [details]
A pic showing that the user avatar settings menu still exists, & works.

I just discovered that the menu labeled "Password & User Account - KDE Control Module" still exists in Fedora 23.  If I remember correctly, it is exactly the same one from Fedora 22 with KDE4.  Furthermore, it seems to work fine.  However, there is no option in "System Settings" that points to it.

So basically, it exists, but there's no way to get to it.  Well I just found a way to get to it, using the program KRename.  Start KRename.  Open up the "Help" menu in the upper left corner, & select "Report Bug...".  Now select "Configure Email...".  This will open up the Password & User Account menu.

I tried it, & it seems to work with no problems.  If it exists & already works, it should be available to use.
Comment 7 3ndymion 2016-01-04 04:02 EST
Created attachment 1111402 [details]
A pic showing the system settings & its incorrect "Account details" option.

RECOMMEND

In System Settings, the Account Details option goes into KDE Wallet Configuration.  This is incorrect.  It should do exactly what it implies & go into the Password & User Account section instead.  KDE Wallet Configuration should have its own, separate option under System Settings.  I believe that's the way it was in Fedora 22 with KDE4.

If the pointer to Password & User Account is unknown, please check KRename.  KRename knows where that menu is located.  The pointer for "Account Details" should be set to "Password & User Account", & "KDE Wallet Configuration" should get its own, separate option in System Settings.  A pointer should also be set for the user avatar in the start menu, since the Password & User Account section exists & works.
Comment 8 3ndymion 2016-01-04 04:10:39 EST
(In reply to Rex Dieter from comment #1)
> True, neither of those are implemented for plasma5/kf5 yet (marking
> FutureFeature)
> 
> 
> There is currently on kde4 based UI provided by kdepasswd, accessible via:
> kcmshell4 useraccount

Oh man, I completely forgot about this from a couple of months ago.  My apologies.  ^_^

But if this one still works fine, wouldn't it be OK to leave it in place until whatever new setup is being created is completed???  I think it would be better than leaving the options empty & non-functional, making Fedora 23 look like it's broken.
Comment 9 Fedora Update System 2016-01-04 07:44:53 EST
plasma-user-manager-5.5.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-dcae5b09bd
Comment 10 3ndymion 2016-01-05 23:54 EST
Created attachment 1112014 [details]
A pic showing the new program's rejection

I tried this new program in the test repository.  Unless I'm doing something wrong, it doesn't seem to work.  It refuses to edit an already existing user, which makes it kind of useless, I think.  Even just trying to add a picture alone is refused.  Any attempt to apply any changes simply clears all fields with the complaint that this username is already used.  Also, "Username must start with a letter".  :(  The original KDE4 user account program can do these things with no problem.
Comment 11 Fedora Update System 2016-01-06 23:22:00 EST
plasma-user-manager-5.5.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.