Bug 1279059 - [Tier]: restarting volume reports "insert/update failure" in cold brick logs
[Tier]: restarting volume reports "insert/update failure" in cold brick logs
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1276248 1277352
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 10:03 EST by Joseph Elwin Fernandes
Modified: 2016-04-19 03:47 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1277352
Environment:
Last Closed: 2016-04-19 03:47:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-11 10:55:25 EST
REVIEW: http://review.gluster.org/12569 (tier/libgfdb: Extending log level flexibity in libgfdb) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-11-11 20:48:42 EST
COMMIT: http://review.gluster.org/12569 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit cdda95b317ea63f30d79a7536f8881aca03c136e
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Nov 10 22:50:55 2015 +0530

    tier/libgfdb: Extending log level flexibity in libgfdb
    
    Extending log level flexibity to relevant fops and operations
    This is an extension to
    http://review.gluster.org/#/c/12491/
    
    Backport of http://review.gluster.org/#/c/12567/
    
    > Change-Id: I33b2f7732f89f52569fb99baa692c7e3bb4c7ab1
    > BUG: 1277352
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12567
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: Idcde04a65775ce98367967faf8a53b0f07ff022e
    BUG: 1279059
    Reviewed-on: http://review.gluster.org/12569
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:47:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.