Bug 1279061 - dnf repoquery does not have a way to show Requires(post/pre/preun/postun)
dnf repoquery does not have a way to show Requires(post/pre/preun/postun)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 10:23 EST by Zbigniew Jędrzejewski-Szmek
Modified: 2016-07-11 10:50 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-11 10:50:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2015-11-07 10:23:53 EST
Description of problem:
dnf repoquery --whatrequires is not symmetrical to dnf repoquery --requires,
because the first one includes e.g. Requires(post), but the second one does not.
I think this should be documented, if this is on purpose, and a way to query those requirements should be added.

Version-Release number of selected component (if applicable):
dnf-plugins-core-0.1.13-1.fc24.noarch

Steps to Reproduce:
1. dnf repoquery --whatrequires systemd-sysv    # This returns a bunch of stuff,
                                                # including e.g. dmapd
2. dnf repoquery --requires dmapd | grep sysv   # This returns nothing.
Comment 1 Michal Luscon 2015-11-09 09:04:36 EST
I am guessing that this can be caused by - https://github.com/rpm-software-management/hawkey/commit/d543c5aa8a2a32abb1c7f95df85f1a9a13e6364a
Comment 2 Harald Hoyer 2016-02-17 11:59:21 EST
any solutions?
Comment 3 Jan Kurik 2016-02-24 08:55:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Fedora Admin XMLRPC Client 2016-07-08 05:25:57 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Štěpán Smetana 2016-07-11 10:49:13 EDT
The capability of showing different requirements was added recently, where command '--requires' shows packages needed for instalation and '--requires-pre' shows packages needed for running of package.

``--requires`` - Display capabilities that the package depends on. Same as ``--qf "%{requires}"``.

``--requires-pre``- Display capabilities that the package depends on for running a ``%pre`` script (Same as ``--qf "%{requires-pre}"``).

Note You need to log in before you can comment on or make changes to this bug.