Bug 1279071 - Nothing to do when performing upgrade
Nothing to do when performing upgrade
Status: CLOSED DUPLICATE of bug 1276886
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 12:09 EST by Michal Konecny
Modified: 2015-11-10 02:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 15:02:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
systemd log (376.82 KB, text/x-vhdl)
2015-11-07 12:09 EST, Michal Konecny
no flags Details
contents of /var/log/dnf.log (6.67 MB, text/plain)
2015-11-09 14:48 EST, Juan Antonio Martinez
no flags Details
dnf.log for November 07 (1.03 MB, text/plain)
2015-11-09 14:51 EST, Michal Konecny
no flags Details

  None (edit)
Description Michal Konecny 2015-11-07 12:09:27 EST
Created attachment 1091009 [details]
systemd log

Description of problem:
After rebooting with dnf-plugin-system-upgrade the system reboots and during system startup it starts update and immediately print "Upgrade complete! Cleaning up and rebooting...". System then boots back to fedora 22. In log you can see that after start of update there are three lines:
lis 07 15:37:47 fedora.localdomain dnf[838]: Dependencies resolved.
lis 07 15:37:47 fedora.localdomain dnf[838]: Nothing to do.
lis 07 15:37:48 fedora.localdomain dnf[838]: Complete!

So no upgrade is actually started. This problem occurs every time and I must download packages again. Systemd log is attached to this report.

Version-Release number of selected component (if applicable):
dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch


How reproducible:
Upgrade system with dnf-plugin-system-upgrade

Steps to Reproduce:
1.dnf system-upgrade download --releasever=23 --best
2.dnf system-upgrade reboot

Actual results:
After nothing done rebooting back to F22.

Expected results:
After reboot system starts upgrade normally.

Additional info:
Comment 1 Juan Antonio Martinez 2015-11-09 08:03:01 EST
I can confirm this issue in some of my computers

In some forums I've found some tips on nvidia cards. This is not my case: I have an intel i3-3225 with in-core GPU intel video card

Also not an i18n dnf issue: all my computers uses LANG=es_ES.UTF-8 at boot cmdline
Comment 2 Will Woods 2015-11-09 14:09:28 EST
Can you attach /var/log/dnf.log?
Comment 3 Juan Antonio Martinez 2015-11-09 14:48 EST
Created attachment 1091947 [details]
contents of /var/log/dnf.log
Comment 4 Michal Konecny 2015-11-09 14:51 EST
Created attachment 1091948 [details]
dnf.log for November 07
Comment 5 Juan Antonio Martinez 2015-11-09 14:52:59 EST
Comment on attachment 1091947 [details]
contents of /var/log/dnf.log

This file contains several dnf system-upgrade sequences. all failed

You can see several references to kmod-VirtualBox-4.1.8-200.fc22.x86_64-4.3.32-1.fc22.x86_64, a package that is automagically installed everytime I reboot. 

I had to manually remove to avoid system-upgrade compatibility error messages. But once removed, the system-upgrade process (download) goes right... until reboot. Then system says that everything is done and refuses to upgrade, returning to normal F22 boot
Comment 6 Michal Konecny 2015-11-09 14:58:01 EST
(In reply to Juan Antonio Martinez from comment #5)
> Comment on attachment 1091947 [details]
> contents of /var/log/dnf.log
> 
> This file contains several dnf system-upgrade sequences. all failed
> 
> You can see several references to
> kmod-VirtualBox-4.1.8-200.fc22.x86_64-4.3.32-1.fc22.x86_64, a package that
> is automagically installed everytime I reboot. 
> 
> I had to manually remove to avoid system-upgrade compatibility error
> messages. But once removed, the system-upgrade process (download) goes
> right... until reboot. Then system says that everything is done and refuses
> to upgrade, returning to normal F22 boot

Same problem for me instead of kmod-VirtualBox I have kmod-nvidia-4.1.10-200.fc22.x86_64.x86_64 2:355.11-1.fc22 installed every time and I must manually remove it before doing dnf system-upgrade reboot. I will try to remove akmods-nvidia before upgrade and I will see if that works.
Comment 7 Juan Antonio Martinez 2015-11-09 15:01:05 EST
More info: as stated in bugzilla, to avoid i18n python dnf issues, I've tried
"sudo localectl set-locale LANT=en_US.UTF-8" and reinit session before dnf system-upgrade sequence. No luck.

In fact all my systems use LANG=es_ES.UTF-8 and I could perform successfully upgrade to F23 in one of them
Comment 8 Will Woods 2015-11-09 15:02:37 EST
Nov 09 20:05:42 DEBUG Completion plugin: Generating completion cache...
Nov 09 20:05:43 INFO Complete!
Nov 09 20:05:43 DEBUG_2 Cleaning up.
Nov 09 20:05:43 DEBUG_2 /var/lib/dnf/system-upgrade/funionfs-0.4.3-15.fc23.x86_64.rpm removed
[etc.]

This is the same root cause as the problems in bug 1276886 - basically if you run any other DNF command between 'download' and 'reboot' (including non-obvious stuff like `dnf-makecache` or the completion plugin) DNF may decide to nuke its cache - including all the downloaded upgrade data.

*** This bug has been marked as a duplicate of bug 1276886 ***

Note You need to log in before you can comment on or make changes to this bug.