Bug 1279084 - SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'open' accesses on the file /dev/shm/steven-ValveIPCSharedObjects5.
SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'open' accesses on the...
Status: CLOSED DUPLICATE of bug 1276305
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e37eff38c3475efa407b1121d38...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 14:53 EST by Steven Schlansker
Modified: 2015-11-08 04:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-08 04:29:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Schlansker 2015-11-07 14:53:00 EST
Description of problem:
Steam crashed, and then abrt crashed trying to generate the bug report.
SELinux is preventing /usr/libexec/abrt-hook-ccpp from 'open' accesses on the file /dev/shm/steven-ValveIPCSharedObjects5.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed open access on the steven-ValveIPCSharedObjects5 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                unconfined_u:object_r:user_tmp_t:s0
Target Objects                /dev/shm/steven-ValveIPCSharedObjects5 [ file ]
Source                        abrt-hook-ccpp
Source Path                   /usr/libexec/abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64 #1 SMP Tue
                              Oct 27 04:29:56 UTC 2015 x86_64 x86_64
Alert Count                   6
First Seen                    2015-11-07 11:51:26 PST
Last Seen                     2015-11-07 11:51:26 PST
Local ID                      0fed5b2e-bf29-4690-b023-1642dbfeffcc

Raw Audit Messages
type=AVC msg=audit(1446925886.523:643): avc:  denied  { open } for  pid=12766 comm="abrt-hook-ccpp" path="/dev/shm/steven-ValveIPCSharedObjects5" dev="tmpfs" ino=48718 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1446925886.523:643): arch=x86_64 syscall=open success=no exit=EACCES a0=5564acb716b0 a1=0 a2=7fff51eaca00 a3=5564acb706d0 items=0 ppid=3248 pid=12766 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-hook-ccpp exe=/usr/libexec/abrt-hook-ccpp subj=system_u:system_r:abrt_dump_oops_t:s0 key=(null)

Hash: abrt-hook-ccpp,abrt_dump_oops_t,user_tmp_t,file,open


Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-08 04:29:47 EST

*** This bug has been marked as a duplicate of bug 1276305 ***

Note You need to log in before you can comment on or make changes to this bug.