Bug 12791 - xlock does not run!
Summary: xlock does not run!
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xlockmore   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-21 19:02 UTC by Sammy
Modified: 2014-03-17 02:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 04:20:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2000-06-21 19:02:01 UTC
version xlockmore-4.16.1-3 gives the following message when executed:

#xlock
BUG IN DYNAMIC LINKER ld.so: dl-version.c: 217: _dl_check_map_versions:
Assertion `needed != ((void *)0)'
failed!

Comment 1 Bill Nottingham 2000-06-21 19:50:09 UTC
I can't reproduce this here. What does 'rpm -q glibc' say?

Comment 2 Sammy 2000-06-21 20:33:03 UTC
rpm -q glibc sais glibc-2.1.90-17

I have the latest (june 15) rawhide rpm's installed for everything but
XF86, KDE, and kernel (I have 2.2.14-12).

# ls -l xlock
-rwxr-xr-x    1 root     root      1683672 Jun 11 14:14 xlock*

Comment 3 Bill Nottingham 2000-06-21 21:06:56 UTC
What X libraries do you have installed?

Comment 4 Bill Nottingham 2000-06-21 21:22:32 UTC
Also, what happens if you do:

rm -f /etc/ld.so.cache
ldconfig

?

Comment 5 Sammy 2000-06-22 13:46:43 UTC
I have the X11 libraries that came with XFree86-4.0-0.16 from rawhide.

doing

rm -f /etc/ld.so.cache
ldconfig

worked fine BUT xlock still gives the same error! I downloaded the previous
xlock binary from tape and that runs fine EXCEPT I could not log back in!
Probably because of /etc/pam.d/xlock file.


Comment 6 Sammy 2000-06-22 14:29:25 UTC
OK. I tried to build xlock from the rpm source on rawhide. The compilation
failed because I seem to be missing some GL headers or something since I get
hundreds of messages like:

/usr/src/redhat/BUILD/xlockmore-4.16.1/modes/glx/rubik.c:723: undefined referenc
e to `glEnd'
/usr/src/redhat/BUILD/xlockmore-4.16.1/modes/glx/rubik.c:726: undefined referenc
e to `glBegin'

I have only the NVIDIA's gl libraries. The previous xlock and all GL stuff
work fine.

PS: Also the /etc/pam.d/xlock seems to be incorrect

Comment 7 Bill Nottingham 2000-08-07 04:20:48 UTC
I still can't reproduce this here. Why do
you say that the pam.d/xlock file looks
incorrect?


Note You need to log in before you can comment on or make changes to this bug.