Bug 1279122 - SELinux is preventing php-fpm from 'write' accesses on the directory cache.
SELinux is preventing php-fpm from 'write' accesses on the directory cache.
Status: CLOSED DUPLICATE of bug 1279114
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a85dab4397e1da9aaf014fe63e8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 19:11 EST by Mikhail
Modified: 2015-11-09 02:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 02:28:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2015-11-07 19:11:03 EST
Description of problem:
SELinux is preventing php-fpm from 'write' accesses on the directory cache.

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If you want to allow httpd to unified
Then you must tell SELinux about this by enabling the 'httpd_unified' boolean.
You can read 'None' man page for more details.
Do
setsebool -P httpd_unified 1

*****  Plugin catchall (11.6 confidence) suggests   **************************

If you believe that php-fpm should be allowed write access on the cache directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep php-fpm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:httpd_t:s0
Target Context                system_u:object_r:httpd_user_content_t:s0
Target Objects                cache [ dir ]
Source                        php-fpm
Source Path                   php-fpm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-153.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64+debug #1 SMP
                              Tue Oct 27 04:11:34 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-08 04:52:49 YEKT
Last Seen                     2015-11-08 04:52:49 YEKT
Local ID                      97f02b8f-9379-4874-a666-46e780a13913

Raw Audit Messages
type=AVC msg=audit(1446940369.131:1951): avc:  denied  { write } for  pid=14856 comm="php-fpm" name="cache" dev="sdb1" ino=64788087 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:object_r:httpd_user_content_t:s0 tclass=dir permissive=1


Hash: php-fpm,httpd_t,httpd_user_content_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-153.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64+debug
type:           libreport

Potential duplicate: bug 927268
Comment 1 Miroslav Grepl 2015-11-09 02:28:32 EST

*** This bug has been marked as a duplicate of bug 1279114 ***

Note You need to log in before you can comment on or make changes to this bug.