Bug 1279123 - SELinux is preventing php-fpm from 'setattr' accesses on the directory 6d4387ff.
SELinux is preventing php-fpm from 'setattr' accesses on the directory 6d4387ff.
Status: CLOSED DUPLICATE of bug 1279114
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:915d741144799be1917e9dc362d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 19:11 EST by Mikhail
Modified: 2015-11-09 02:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 02:28:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2015-11-07 19:11:24 EST
Description of problem:
SELinux is preventing php-fpm from 'setattr' accesses on the directory 6d4387ff.

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If you want to allow httpd to unified
Then you must tell SELinux about this by enabling the 'httpd_unified' boolean.
You can read 'None' man page for more details.
Do
setsebool -P httpd_unified 1

*****  Plugin catchall (11.6 confidence) suggests   **************************

If you believe that php-fpm should be allowed setattr access on the 6d4387ff directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep php-fpm /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:httpd_t:s0
Target Context                system_u:object_r:httpd_user_content_t:s0
Target Objects                6d4387ff [ dir ]
Source                        php-fpm
Source Path                   php-fpm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-153.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64+debug #1 SMP
                              Tue Oct 27 04:11:34 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-08 04:51:49 YEKT
Last Seen                     2015-11-08 04:51:49 YEKT
Local ID                      c1880e93-a84b-44ec-97eb-4a79a8f4d328

Raw Audit Messages
type=AVC msg=audit(1446940309.264:1934): avc:  denied  { setattr } for  pid=15542 comm="php-fpm" name="6d4387ff" dev="sdb1" ino=64787965 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:object_r:httpd_user_content_t:s0 tclass=dir permissive=1


Hash: php-fpm,httpd_t,httpd_user_content_t,dir,setattr

Version-Release number of selected component:
selinux-policy-3.13.1-153.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64+debug
type:           libreport
Comment 1 Miroslav Grepl 2015-11-09 02:28:38 EST

*** This bug has been marked as a duplicate of bug 1279114 ***

Note You need to log in before you can comment on or make changes to this bug.