Bug 1279183 - Window from panel opens into new workspace even if number workspaces is set to 1
Window from panel opens into new workspace even if number workspaces is set to 1
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-panel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 08:14 EST by Assen Totin
Modified: 2015-11-10 06:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 06:02:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Assen Totin 2015-11-08 08:14:16 EST
Description of problem:
Sometimes when a minimized window is clicked in panel (windows list), it is opened into a new (second) workspace, even if the number of workspaces is explicitly set to 1.

Version-Release number of selected component (if applicable):
mate-panel-1.10.1-1.fc23.i686
compiz-0.8.8-30.fc23.i686

How reproducible:
Once every 10-20 times, probably when there are few windows already visible on the primary workspace.

Steps to Reproduce:
1. Set the number of workspaces to 1 using dconf. Reboot to make sure seting is in effect.
2. Open 5 or more windows.
3. Minimise 1-2 of them, keep the rest visible.
4. Click a minimised window in panel (window list) to show it.

Actual results:
Sometimes, the window is opened in a new workspace.

Expected results:
Since the number of workspaces is set to be 1, the window should always be brought up in the current (one and only) workspace.

Additional info:
I find multiple workspaces inconvenient and never use them. Since F23, however, bringing up a window from the window list sometimes opens the windows an a new workspace. When this happens, I need to press Ctls + Alt + Left_Arrow to get back to my original workspace. At the same time, the workspace switcher is shown having 4 workspaces (even though I have set the number of workspaces to be 1). 

Window manager is compiz-mate-gtk. 

This has never happened in previous versions of Fedora + MATE (and I have run MATE on Fedora at least since F18 - always with "Desktop effects" enabled, i.e. with compiz-mate-gtk running).

Trying to fix this behavior, I have explicitly set the number of workspaces to 1, but this still happens, hence it is bug: 
[assen@archimed ~]$ dconf read /org/mate/marco/general/num-workspaces
1
Comment 1 Wolfgang Ulbrich 2015-11-08 08:35:09 EST
Hi Assen,
if you use compiz you need to set up the workspaces with ccsm.
It's all in general plugin.
Compiz don't use dconf/gsettings, so setting something in marco settings doesn't have any effect.
In ccsm use virtual-desktops to set the workspaces.
Comment 2 Assen Totin 2015-11-09 17:53:41 EST
Thanks, Wolfgang, 

Haven't realised that before - just for the record, the setting is General Options -> Desktop Size -> Horizontal Virtual Size.

This can be now closed.
Comment 3 Wolfgang Ulbrich 2015-11-10 06:02:44 EST
Good, reporters can also close reports ;)

Note You need to log in before you can comment on or make changes to this bug.