Bug 1279195 - [abrt] pan: PanTreeStore::get_iter(): pan killed by SIGABRT
[abrt] pan: PanTreeStore::get_iter(): pan killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pan (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Kovar
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:2bebd498ce79a99ae5a25bb1a6a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 09:54 EST by Jérôme Benoit
Modified: 2016-01-26 13:28 EST (History)
5 users (show)

See Also:
Fixed In Version: pan-0.140-0.1.20160114git.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 13:28:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: cgroup (190 bytes, text/plain)
2015-11-08 09:54 EST, Jérôme Benoit
no flags Details
File: core_backtrace (7.95 KB, text/plain)
2015-11-08 09:54 EST, Jérôme Benoit
no flags Details
File: dso_list (10.47 KB, text/plain)
2015-11-08 09:54 EST, Jérôme Benoit
no flags Details
File: environ (3.48 KB, text/plain)
2015-11-08 09:54 EST, Jérôme Benoit
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-08 09:54 EST, Jérôme Benoit
no flags Details
File: maps (52.44 KB, text/plain)
2015-11-08 09:54 EST, Jérôme Benoit
no flags Details
File: mountinfo (4.16 KB, text/plain)
2015-11-08 09:55 EST, Jérôme Benoit
no flags Details
File: namespaces (85 bytes, text/plain)
2015-11-08 09:55 EST, Jérôme Benoit
no flags Details
File: open_fds (740 bytes, text/plain)
2015-11-08 09:55 EST, Jérôme Benoit
no flags Details
File: proc_pid_status (1010 bytes, text/plain)
2015-11-08 09:55 EST, Jérôme Benoit
no flags Details
File: var_log_messages (648 bytes, text/plain)
2015-11-08 09:55 EST, Jérôme Benoit
no flags Details
File: backtrace (16.00 MB, text/plain)
2015-11-08 09:56 EST, Jérôme Benoit
no flags Details
Diff (Patch) which should fix crash at start of Pan at PanTreeStore::get_iter() (2.31 KB, text/plain)
2016-01-08 14:42 EST, Detlef Graef
no flags Details

  None (edit)
Description Jérôme Benoit 2015-11-08 09:54:47 EST
Description of problem:
Starting up PAN. 

Version-Release number of selected component:
pan-0.139-10.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        pan
crash_function: PanTreeStore::get_iter
executable:     /usr/bin/pan
global_pid:     13112
kernel:         4.2.5-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Potential duplicate: bug 1010825
Comment 1 Jérôme Benoit 2015-11-08 09:54:51 EST
Created attachment 1091265 [details]
File: cgroup
Comment 2 Jérôme Benoit 2015-11-08 09:54:53 EST
Created attachment 1091266 [details]
File: core_backtrace
Comment 3 Jérôme Benoit 2015-11-08 09:54:54 EST
Created attachment 1091267 [details]
File: dso_list
Comment 4 Jérôme Benoit 2015-11-08 09:54:56 EST
Created attachment 1091268 [details]
File: environ
Comment 5 Jérôme Benoit 2015-11-08 09:54:57 EST
Created attachment 1091269 [details]
File: limits
Comment 6 Jérôme Benoit 2015-11-08 09:54:58 EST
Created attachment 1091270 [details]
File: maps
Comment 7 Jérôme Benoit 2015-11-08 09:55:00 EST
Created attachment 1091271 [details]
File: mountinfo
Comment 8 Jérôme Benoit 2015-11-08 09:55:01 EST
Created attachment 1091272 [details]
File: namespaces
Comment 9 Jérôme Benoit 2015-11-08 09:55:03 EST
Created attachment 1091273 [details]
File: open_fds
Comment 10 Jérôme Benoit 2015-11-08 09:55:04 EST
Created attachment 1091274 [details]
File: proc_pid_status
Comment 11 Jérôme Benoit 2015-11-08 09:55:05 EST
Created attachment 1091275 [details]
File: var_log_messages
Comment 12 Jérôme Benoit 2015-11-08 09:56:00 EST
Created attachment 1091276 [details]
File: backtrace
Comment 13 Detlef Graef 2015-12-16 04:46:04 EST
After upgrading from Fedora 22 to Fedora 23 pan crashes on start.

uname -a
Linux 4.2.6-301.fc23.x86_64 #1 SMP Fri Nov 20 22:22:41 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

rpm -qa |grep -i pan-0
pan-0.139-11.fc23.x86_64

Problem occurs not only on Fedora. See Bug report:

https://bugzilla.gnome.org/show_bug.cgi?id=756458

Problem is like described in comment #2:

https://bugzilla.gnome.org/show_bug.cgi?id=756458#c2
Comment 14 Detlef Graef 2015-12-19 11:29:27 EST
It ssems a patch for this problem is available:

https://bugzilla.gnome.org/show_bug.cgi?id=754698

g++-5: newsrc-* files are created in current working directory instead of ~/.pan due to change in std::string return semantics


I hope the developer of pan will release soon a new, fixed version of pan.
Comment 15 Petr Kovar 2015-12-20 20:09:02 EST
(In reply to Detlef Graef from comment #14)
> It ssems a patch for this problem is available:
> 
> https://bugzilla.gnome.org/show_bug.cgi?id=754698
> 
> g++-5: newsrc-* files are created in current working directory instead of
> ~/.pan due to change in std::string return semantics

Thanks for taking time to report this!

I've created a test build of pan based on latest master branch:

http://koji.fedoraproject.org/koji/taskinfo?taskID=12263701

You can grab pan-0.140-0.1.20151221git.fc23.x86_64.rpm from here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=12263703

Let me know if that build works for you and if it fixes at least some of the crashes. Thanks again.
Comment 16 Detlef Graef 2015-12-21 13:15:12 EST
Thanks for commiting the patch.

First I've removed pan 0.139:

"dnf remove pan-0.139-11.fc23.x86_64"

Then I've installed pan 0.140:

"rpm -i pan-0.140-0.1.20151221git.fc23.x86_64.rpm"

Checked the version:

"pan --version"
Pan 0.140

Then I started with a non existing directory ~/.pan2

I've configured pan (3 news-servers and subscribed some newsgroups) and quit/started it several times. The files newsrc-1, newsrc-2 etc. are now written correctly to ~/.pan2. Before they were written mostly to ~/ or sometimes to ~/.pan2.

But eventually pan doesn't start anymore:

pan --debug &
[1] 31606
(article-cache.cc:171:ArticleCache) loaded 27 articles into cache from /home/user/.pan2/article-cache
GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name news.pan.NZB was not provided by any .service files
**
ERROR:pan-tree.cc:80:GtkTreeIter PanTreeStore::get_iter(const PanTreeStore::Row*): assertion failed: (row)

[1]+  Abgebrochen             (Speicherabzug geschrieben) pan --debug

Conclusion:

One bug [get_pan_home()] fixed, but there is at least one bug remaining.

A good starting point to look at this is probably the file

pan-tree.cc (at line 80?).

Sadly I've no C++ knowledge.
Comment 17 Petr Kovar 2015-12-21 20:51:59 EST
(In reply to Detlef Graef from comment #16)
> Thanks for commiting the patch.
> 
> First I've removed pan 0.139:
> 
> "dnf remove pan-0.139-11.fc23.x86_64"
> 
> Then I've installed pan 0.140:
> 
> "rpm -i pan-0.140-0.1.20151221git.fc23.x86_64.rpm"
> 
> Checked the version:
> 
> "pan --version"
> Pan 0.140
> 
> Then I started with a non existing directory ~/.pan2
> 
> I've configured pan (3 news-servers and subscribed some newsgroups) and
> quit/started it several times. The files newsrc-1, newsrc-2 etc. are now
> written correctly to ~/.pan2. Before they were written mostly to ~/ or
> sometimes to ~/.pan2.
> 
> But eventually pan doesn't start anymore:

Thanks for following up, Detlef. Could you test with  pan-0.140-0.1.20151221git.fc23.x86_64.rpm from here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=12276231

?

That build adds -D_GLIBCXX_USE_CXX11_ABI=0 to use the old ABI which was default in previous Fedora releases.
Comment 18 Detlef Graef 2015-12-23 11:16:45 EST
I've tested this new build.

I have had no crashes with this build (with option: -D_GLIBCXX_USE_CXX11_ABI=0) so far.

Thanks.
Comment 19 Detlef Graef 2016-01-05 14:26:10 EST
I've some update. I've done some debugging.

I think the source has to be fixed at least in the file prefs.cc at this place to fix the crash of Pan at startup (when build with option: -D_GLIBCXX_USE_CXX11_ABI=1):



/***
****  STRINGS
***/

std::string
Prefs :: get_string (const StringView& key, const StringView& fallback)
const
{
  if (!_strings.count (key))
    _strings[key] = fallback;
  return _strings[key];
}



When I look at the diff from the patch for "get_pan_home()":

https://bugzilla.gnome.org/attachment.cgi?id=310852&action=diff

it looks similar to me.

The function above is invoked at least with these keys:

key: header-pane-show-matching
key: header-pane-columns
key: body-pane-font
key: pane-layout
key: pane-orient
key: last-visited-group
Comment 20 Detlef Graef 2016-01-08 14:42 EST
Created attachment 1112967 [details]
Diff (Patch) which should fix crash at start of Pan at PanTreeStore::get_iter()

Diff of files to patch Pan source from current git repository.

I've tested it, problem is fixed. Other users should test it too.

I hope the patch meets the requirements (else just ignore the patch) and doesn't cause any other problems.
Comment 21 Petr Kovar 2016-01-13 11:13:02 EST
(In reply to Detlef Graef from comment #20)
> Created attachment 1112967 [details]
> Diff (Patch) which should fix crash at start of Pan at
> PanTreeStore::get_iter()
> 
> Diff of files to patch Pan source from current git repository.
> 
> I've tested it, problem is fixed. Other users should test it too.
> 
> I hope the patch meets the requirements (else just ignore the patch) and
> doesn't cause any other problems.

Thank you, pushed to upstream master as 366372076042687a0bf21cf72c7693e4a7c2b3d6.
Comment 22 Fedora Update System 2016-01-14 13:18:40 EST
pan-0.140-0.1.20160114git.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0b77a47e8b
Comment 23 Fedora Update System 2016-01-15 13:52:57 EST
pan-0.140-0.1.20160114git.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0b77a47e8b
Comment 24 Jérôme Benoit 2016-01-21 09:09:35 EST
Another user experienced a similar problem:

Starting PAN

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        pan
crash_function: PanTreeStore::get_iter
executable:     /usr/bin/pan
global_pid:     6481
kernel:         4.3.3-301.fc23.x86_64
package:        pan-0.139-11.fc23
reason:         pan killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 25 Detlef Graef 2016-01-21 11:47:03 EST
(In reply to Jérôme Benoit from comment #24)
> Another user experienced a similar problem:
> 
> Starting PAN
> 
> package:        pan-0.139-11.fc23

Please test the following version of Pan:

pan-0.140-0.1.20160114git.fc23 

See comment #23 of this bugreport.
Comment 26 Fedora Update System 2016-01-26 13:28:10 EST
pan-0.140-0.1.20160114git.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.