Bug 1279214 - [epel7s390x] jboss-jstl-1.2-api SRPM does not build correctly on s390x (using IBM Java)
[epel7s390x] jboss-jstl-1.2-api SRPM does not build correctly on s390x (usin...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: jboss-jstl-1.2-api (Show other bugs)
epel7
s390x Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Mráka
Fedora Extras Quality Assurance
:
Depends On:
Blocks: epel7s390x
  Show dependency treegraph
 
Reported: 2015-11-08 11:11 EST by IBM Bug Proxy
Modified: 2016-07-19 04:23 EDT (History)
7 users (show)

See Also:
Fixed In Version: jboss-jstl-1.2-api-1.0.3-13.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-18 14:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to endorse xalan-j2.jar on IBM JDK (1.77 KB, text/plain)
2015-11-08 11:12 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 131755 None None None Never

  None (edit)
Description IBM Bug Proxy 2015-11-08 11:11:57 EST

    
Comment 1 IBM Bug Proxy 2015-11-08 11:11:59 EST
The EPEL 7 SRPM for jboss-jstl-1.2-api 
https://dl.fedoraproject.org/pub/epel/7/SRPMS/j/jboss-jstl-1.2-api-1.0.3-10.el7.src.rpm
does not build correctly in Mock on s390x. 

The extension xml.jar shipped with IBM JDK already contains a version of class "org.apache.xpath.res.XPATHErrorResources", which is incompatible with this SRPM. Thus building this project would fail due to "symbol cannot be found" compilation error. 

We can fix this issue by specifying openJDK (instead of java-devel) as the build requirement in spec file for now.

We have found a workaround to fix this issue.

We add 2 maven plugins:
1. copying xalan-j2.jar to a directory under build directory 
2. use -Djava.endorsed.dirs option to endorse the directory which contains the copied jar.

After applying these changes, jboss-jstl can be built correctly on s390x.

Ideally, it would be better to endorse /usr/share/java instead, as this is where xalan-j2.jar originally located in Mock. 

However, endorsing that directory will create another conflict. To avoid this conflict, xalan-j2.jar is copied to a different directory and that directory is endorsed instead.
Comment 2 IBM Bug Proxy 2015-11-08 11:12:05 EST
Created attachment 1091300 [details]
patch to endorse xalan-j2.jar on IBM JDK
Comment 3 IBM Bug Proxy 2015-11-11 05:35:28 EST
------- Comment From bugproxy@us.ibm.com 2015-11-08 17:13 EDT-------
Comment 4 Michael Mráka 2015-11-11 06:34:06 EST
Applied in
http://pkgs.fedoraproject.org/cgit/jboss-jstl-1.2-api.git/commit/?h=epel7&
id=936e97059a75c150fd9de7e45901d43ea5c4541f

New Package
http://koji.fedoraproject.org/koji/taskinfo?taskID=11790604
Comment 5 IBM Bug Proxy 2015-11-11 06:43:51 EST
------- Comment From bugproxy@us.ibm.com 2015-11-11 12:45 EDT-------
Comment 6 Fedora Update System 2015-11-11 07:04:26 EST
jboss-jstl-1.2-api-1.0.3-13.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-48ef56dfbb
Comment 7 IBM Bug Proxy 2015-11-11 07:13:44 EST
------- Comment From bugproxy@us.ibm.com 2015-11-11 13:14 EDT-------
Comment 8 Fedora Update System 2015-11-11 14:20:36 EST
jboss-jstl-1.2-api-1.0.3-13.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update jboss-jstl-1.2-api'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-48ef56dfbb
Comment 9 IBM Bug Proxy 2015-12-02 16:00:24 EST
------- Comment From zwilliam@ca.ibm.com 2015-12-02 20:55 EDT-------
I just tested the new SRPM from https://dl.fedoraproject.org/pub/epel/testing/7/SRPMS/j/jboss-jstl-1.2-api-1.0.3-13.el7.src.rpm. I can build this SRPM on s390x on Mock now. Thank you!
Comment 10 IBM Bug Proxy 2016-03-16 07:01:23 EDT
------- Comment From vsandhya@in.ibm.com 2016-03-16 06:57 EDT-------
Closing as per previous comment
Comment 11 gil cattaneo 2016-06-14 13:06:44 EDT
Now we use pom macros, patch1 is removed in 1.1.2.Final
see https://bugzilla.redhat.com/attachment.cgi?id=1167932
Comment 12 gil cattaneo 2016-07-06 07:24:18 EDT
sorry, how much longer this bug will have to stay open?
It has not already been solved?
Thanks in advance
Comment 13 Fedora Update System 2016-07-18 14:50:06 EDT
jboss-jstl-1.2-api-1.0.3-13.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.