Bug 1279217 - [abrt] dnf: system_upgrade.py:359:__init__:TypeError: must be type, not None
[abrt] dnf: system_upgrade.py:359:__init__:TypeError: must be type, not None
Status: CLOSED DUPLICATE of bug 1278031
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:3feab66d7eebbda6531b71d6796...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 11:41 EST by webdesigner
Modified: 2015-11-18 07:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 07:35:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (42.53 KB, text/plain)
2015-11-08 11:41 EST, webdesigner
no flags Details
File: backtrace (1.14 KB, text/plain)
2015-11-08 11:41 EST, webdesigner
no flags Details
File: dnf-makecache.log (713.61 KB, text/plain)
2015-11-08 11:41 EST, webdesigner
no flags Details
File: dso_list (84 bytes, text/plain)
2015-11-08 11:41 EST, webdesigner
no flags Details
File: environ (90 bytes, text/plain)
2015-11-08 11:41 EST, webdesigner
no flags Details

  None (edit)
Description webdesigner 2015-11-08 11:41:33 EST
Version-Release number of selected component:
dnf-1.1.3-1.fc22

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python -OO /bin/dnf -y install --disablerepo=* /tmp/akmods.nTga3Ieb/results/kmod-VirtualBox-4.2.5-201.fc22.x86_64-4.3.32-1.fc22.x86_64.rpm
executable:     /bin/dnf
kernel:         4.2.3-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
system_upgrade.py:359:__init__:TypeError: must be type, not None

Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 117, in _main
    cli.configure(map(ucd, args))
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1006, in configure
    self.base.plugins.run_init(self.base, self)
  File "/usr/lib/python2.7/site-packages/dnf/plugin.py", line 104, in run_init
    plugin = p_cls(base, cli)
  File "/usr/lib/python2.7/site-packages/dnf-plugins/system_upgrade.py", line 359, in __init__
    super(SystemUpgradePlugin, self).__init__(base, cli)
TypeError: must be type, not None

Local variables in innermost frame:
self: <dnf.plugin.dynamic.system_upgrade.SystemUpgradePlugin object at 0x7f1530e12090>
base: <dnf.cli.cli.BaseCli object at 0x7f15329e7610>
cli: <dnf.cli.cli.Cli object at 0x7f15329efd90>
Comment 1 webdesigner 2015-11-08 11:41:38 EST
Created attachment 1091302 [details]
File: _var_log_dnf.log
Comment 2 webdesigner 2015-11-08 11:41:40 EST
Created attachment 1091303 [details]
File: backtrace
Comment 3 webdesigner 2015-11-08 11:41:45 EST
Created attachment 1091304 [details]
File: dnf-makecache.log
Comment 4 webdesigner 2015-11-08 11:41:46 EST
Created attachment 1091305 [details]
File: dso_list
Comment 5 webdesigner 2015-11-08 11:41:48 EST
Created attachment 1091306 [details]
File: environ
Comment 6 Honza Silhan 2015-11-18 07:35:57 EST

*** This bug has been marked as a duplicate of bug 1278031 ***

Note You need to log in before you can comment on or make changes to this bug.