Bug 1279232 - SELinux is preventing hp-config_usb_p from 'add_name' accesses on the directory .hplip.
SELinux is preventing hp-config_usb_p from 'add_name' accesses on the directo...
Status: CLOSED DUPLICATE of bug 1282812
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:eec4b91ca75bd968c27a6d439bb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 14:02 EST by Martín Cigorraga
Modified: 2016-01-07 18:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 10:58:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martín Cigorraga 2015-11-08 14:02:00 EST
Description of problem:
SELinux is preventing hp-config_usb_p from 'add_name' accesses on the directory .hplip.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that hp-config_usb_p should be allowed add_name access on the .hplip directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep hp-config_usb_p /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .hplip [ dir ]
Source                        hp-config_usb_p
Source Path                   hp-config_usb_p
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-153.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.5-300.fc23.x86_64 #1 SMP Tue
                              Oct 27 04:29:56 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-08 16:01:37 ART
Last Seen                     2015-11-08 16:01:37 ART
Local ID                      4c7d1b22-7421-4e4f-b001-f31d8c52ef78

Raw Audit Messages
type=AVC msg=audit(1447009297.282:588): avc:  denied  { add_name } for  pid=5433 comm="hp-config_usb_p" name=".hplip" scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir permissive=0


Hash: hp-config_usb_p,cupsd_t,admin_home_t,dir,add_name

Version-Release number of selected component:
selinux-policy-3.13.1-153.fc23.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.5-300.fc23.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2015-11-20 05:05:01 EST
Martín,
does hp-config_usb_p place a config in /root directory?
Comment 2 Jiri Popelka 2015-11-23 10:58:57 EST
Looks like duplicate of bug #1282812

*** This bug has been marked as a duplicate of bug 1282812 ***

Note You need to log in before you can comment on or make changes to this bug.