Bug 1279238 - No sound - HP Spectre x360 - Fedora 23
No sound - HP Spectre x360 - Fedora 23
Status: CLOSED DUPLICATE of bug 1350534
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 14:30 EST by Saman Porhemmat
Modified: 2016-07-26 16:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-25 08:20:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saman Porhemmat 2015-11-08 14:30:44 EST
Description of problem:

I Installed Fedora 23 Gnome on HP Spectre x360. Everything works fine except that there is no sound!

I googled and searched about this problem and realized that this is a common bug when people install Linux. 

I did the following and the problem is fixed now:

1. sudo gedit /etc/default/grub
2. Edit the line: GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet"

and replace it with:
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'"


3. Run this command: sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

4. Reboot TWO times and the problem should be solved.

If you have Fedora 22 installed and encountering this problem, check the following link:

https://bugzilla.redhat.com/show_bug.cgi?id=1220709


Hope this helps
Comment 1 morgan read 2016-07-17 11:59:34 EDT
I'm unsure 'acpi_backlight=vendor' is necessary in f24.  It seems unconnected with this sound bug, but was necessary to have keyboard back-light working, but seems unnecessary for the back-light or (if it ever was) this sound bug in f24
Comment 2 morgan read 2016-07-17 12:00:40 EDT
Apart from Comment 1, can this bug be bumped to f24 please - sound still not working.
Comment 3 morgan read 2016-07-23 18:03:39 EDT
This bug seems (perhaps) fixed in f24, see here:
https://bugzilla.redhat.com/show_bug.cgi?id=1350534#c13
Comment 4 Josh Boyer 2016-07-25 08:20:53 EDT

*** This bug has been marked as a duplicate of bug 1350534 ***
Comment 5 morgan read 2016-07-26 16:36:36 EDT
Now working for me in f24, see Bug 1350534

Note You need to log in before you can comment on or make changes to this bug.