Bug 127924 - [PATCH] MAILTO option in anacrontab
[PATCH] MAILTO option in anacrontab
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
: FutureFeature
Depends On:
Blocks: FC3BugWeekTracker
  Show dependency treegraph
 
Reported: 2004-07-15 09:04 EDT by Paul Bolle
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.3-32
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-07 13:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The patch I promised in my bugreport (1.45 KB, patch)
2004-07-15 09:06 EDT, Paul Bolle
no flags Details | Diff

  None (edit)
Description Paul Bolle 2004-07-15 09:04:50 EDT
Description of problem: cron has a MAILTO option in crontab (and
logwatch has a MailtTo option in logwatch.conf). anacron doesn't have
a MAILTO option in anacrontab.


Version-Release number of selected component (if applicable): 2.3-31


Additional info: I'll attach a patch which enables a MAILTO option for
anacrontab.

anacron hasn't seen any serious development in years. Therefor I
didn't even consider sending this patch "upstreams". I realise that
the chance for my patch to be accepted are quite small under these
conditions ...
Comment 1 Paul Bolle 2004-07-15 09:06:04 EDT
Created attachment 101939 [details]
The patch I promised in my bugreport
Comment 2 Rik van Riel 2004-09-27 18:18:24 EDT
The patch looks good to me.

Jason, any objections if I apply it for rawhide as one of the bug week
activities ? ;)
Comment 3 Rik van Riel 2004-09-27 18:20:49 EDT
Adding to the bug week tracker.  Since the patch is available this one
should be easy to fix ;)
Comment 4 Paul Bolle 2004-09-27 20:13:50 EDT
1) Would the debian maintainer qualify as upstreams? Anyway, maybe you
should have a quick look at this debian bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=223337. (I'm not sure
whether the "commited" patch is on that page.)

The debain people seem to have fixed/changed more than I did and
included an update to the manpage (and all that just a few days
earlier too!).

2) It seems wise to add "MAILTO=root" to /etc/anacrontab (to make this
new feature more obvious).
Comment 5 Michael Schwendt 2004-09-28 12:31:15 EDT
Debian's MAILTO patch has been merged into this one:
http://ftp.debian.org/debian/pool/main/a/anacron/anacron_2.3-10.diff.gz

They have implemented a bit more, such as adding the hostname in the
subject line, which makes sense since you can MAILTO a different host.
Should be easy to extract the pieces of the patch.

But the patch looks as if it could clash with
anacron-2.3-mail-content-type-77108.patch, so merging/regenerating
that one might be necessary.
Comment 6 Rik van Riel 2004-09-28 12:33:41 EDT
Patch applied for anacron-2.3-38 (the one from comment #1) and MAILTO
line added to /etc/anacrontab.
Comment 7 Paul Bolle 2005-07-30 17:48:37 EDT
According to my "Bugzilla Front Page" this bug is still open: "it is now
resolved and you should verify it." Hmmm.

What do you want me (this bug's reporter) to actually do in order to "verify" it?

Note You need to log in before you can comment on or make changes to this bug.