Bug 1279274 - How to clean all packages and configuration of openshift-master, openshift-node, and docker
How to clean all packages and configuration of openshift-master, openshift-no...
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Vikram Goyal
Vikram Goyal
Vikram Goyal
https://access.redhat.com/documentati...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 20:11 EST by Naoya Hashimoto
Modified: 2016-06-10 20:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-10 20:54:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naoya Hashimoto 2015-11-08 20:11:14 EST
Document URL: 
https://access.redhat.com/documentation/en/openshift-enterprise/version-3.0/openshift-enterprise-30-installation-and-configuration/chapter-2-installing

Section Number and Name: 
2.4.9. Known Issues

Describe the issue: 
I'm looking for the official instruction that relates to the subject.
It seems that that the topic in the section is the only document that relates to the matter.

Suggestions for improvement: 
Could you add a new topic or section about the subject in the official document because the topic is defined in the Multiple Masters section right now and it is hard to find and trace the related subject.

Additional information: 
The exact topic I mentioned is as follows.

Then, run the following on all node hosts:

# yum -y remove openshift openshift-* etcd docker

# rm -rf /etc/openshift /var/lib/openshift /etc/etcd \
    /var/lib/etcd /etc/sysconfig/openshift* /etc/sysconfig/docker* \
    /root/.kube/config /etc/ansible/facts.d /usr/share/openshift
Comment 3 Kenjiro Nakayama 2015-11-16 20:25:30 EST
It seems that new OSE installer which will release with v3.1 fix this.

https://docs.openshift.com/enterprise/3.1/install_config/install/quick_install.html#uninstalling-openshift-quick
Comment 4 Naoya Hashimoto 2016-06-09 22:10:51 EDT
(In reply to Kenjiro Nakayama from comment #3)
> It seems that new OSE installer which will release with v3.1 fix this.
> 
> https://docs.openshift.com/enterprise/3.1/install_config/install/
> quick_install.html#uninstalling-openshift-quick
Yes, we can close this issue.
Comment 5 Vikram Goyal 2016-06-10 20:54:08 EDT
Thank you Kenjiro and Naoya. Based on your comments, I will close this issue.

Note You need to log in before you can comment on or make changes to this bug.