Bug 1279287 - rhc cannot detect ssh.exe from git 2.6.2.windows.1
rhc cannot detect ssh.exe from git 2.6.2.windows.1
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
x86_64 Windows
unspecified Severity medium
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 22:14 EST by Yudhi Widyatama
Modified: 2017-05-31 14:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-31 14:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yudhi Widyatama 2015-11-08 22:14:18 EST
Description of problem:
Using git version 2.6.2, rhc is unable to detect the location ssh.exe

Version-Release number of selected component (if applicable):
rhc 1.38.4 / git 2.6.2.windows.1

How reproducible:
Always, if PC is clean from previous git versions (git 2.6.2 is the only one installed)

Steps to Reproduce:
1. Ensure putty not installed, uninstall putty if necessary
2. Install git version 2.6.2 64-bit
3. Open ruby command prompt
4. git version -> ensure 2.6.2 is shown
5. rhc ssh -a appname -> try to ssh to one app

Actual results:

D:\SourceCode\www>git version
git version 2.6.2.windows.1

D:\SourceCode\www>rhc ssh -a testmed54 -n test
DL is deprecated, please use Fiddle
No system SSH available. Please use the --ssh option to specify the path to your

SSH executable, or install SSH. We recommend this free application: Git for
Windows - a basic git command line and GUI client http://msysgit.github.io/.

Expected results:
SSH performed successfully using git's ssh.exe

Additional info:
The cause is ssh.exe is being recently moved from Git/bin to Git/usr/bin.

My Suggestion is to modify lib\rhc\ssh_helpers.rb to append this @line 488 :
"#{base}\\Git\\usr\\bin\\ssh.exe",
Comment 1 Eric Paris 2017-05-31 14:22:11 EDT
We apologize, however, we do not plan to address this report at this time. The majority of our active development is for the v3 version of OpenShift. If you would like for Red Hat to reconsider this decision, please reach out to your support representative. We are very sorry for any inconvenience this may cause.

Note You need to log in before you can comment on or make changes to this bug.